summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorneoninteger2019-06-05 18:37:09 +0930
committerneoninteger2019-06-05 18:37:09 +0930
commit4ec9eb78317c6dacc61663c1c14981e7b6cd5d72 (patch)
tree6f649feec3acc75e0f81e52586d7c8fcb83ebabb /PKGBUILD
parentff0ff563acbd1f8cf499407146a9f9bf0aa6ef3e (diff)
downloadaur-4ec9eb78317c6dacc61663c1c14981e7b6cd5d72.tar.gz
Update to v0.7.2.6-pre-sync-fix
* Added new variable _pkgstring which contains the version number followed by its text string (pre-sync-fix in this case) * Corrected dependencies according to namcap * Replaced MD5 checksums with SHA256 checksums from Turtl's website
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8644c23e835..b34bc3f101e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,22 @@
-# Maintainer: Manuel Mazzuola <origin.of@gmail.com>
-# This particular update is brought to you by gaalcaras (https://keybase.io/gaalcaras)
+# Maintainer: Callum Parsey <neoninteger@protonmail.com>
+# Contributor: Manuel Mazzuola <origin.of@gmail.com>
+# Contributor: gaalcaras (https://keybase.io/gaalcaras)
pkgname=turtl
-pkgver=0.7.2.5
+pkgver=0.7.2.6
+_pkgstring=0.7.2.6-pre-sync-fix
pkgrel=1
-pkgdesc="Turtl lets you take notes, bookmark websites, and store documents for sensitive projects."
+pkgdesc="The secure, collaborative notebook"
arch=('i686' 'x86_64')
url="https://turtlapp.com/"
-depends=('gconf' 'gendesk' 'libxss')
+depends=('alsa-lib' 'gconf' 'gtk2' 'libxss' 'libxtst' 'nss' 'python')
+makedepends=('gendesk')
license=('GPL3')
source=("turtl.png")
-source_i686=("https://github.com/turtl/desktop/releases/download/v$pkgver/$pkgname-$pkgver-linux32.tar.bz2")
-source_x86_64=("https://github.com/turtl/desktop/releases/download/v$pkgver/$pkgname-$pkgver-linux64.tar.bz2")
-md5sums=('9e99b3fe83cb796343b7f1b21959f0d7')
-md5sums_i686=('e85d853dccadcb5a8f6a5478cd038690')
-md5sums_x86_64=('771ac3060d5e6d13fcd1bb4644772999')
+source_i686=("https://github.com/turtl/desktop/releases/download/v$_pkgstring/$pkgname-$_pkgstring-linux32.tar.bz2")
+source_x86_64=("https://github.com/turtl/desktop/releases/download/v$_pkgstring/$pkgname-$_pkgstring-linux64.tar.bz2")
+sha256sums=('97036fdfca0e354363bc28f1952af6e63b85907a8292d2f121905130cee23e07')
+sha256sums_i686=('3644e521b8ce763cd58fb2394445f17706296b8aa594564d50b1d5b5126bff40')
+sha256sums_x86_64=('77746d54518aabf19c187c6fb3c9923fe84acad30a68073fee50ba5f61a96bde')
[[ "$CARCH" = "i686" ]] && _pkg="$pkgname-linux32"
[[ "$CARCH" = "x86_64" ]] && _pkg="$pkgname-linux64"