summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOwen Trigueros2019-06-11 16:02:46 +0200
committerOwen Trigueros2019-06-11 16:02:46 +0200
commit28ce6aea49dee8c3057c20f8150f6872dec199fb (patch)
tree6eae7c349ecb8933aadb471e3b4bf3cd5bc89653 /PKGBUILD
parent225318c66fb2e054a09aa81dc29e376ea241ae7e (diff)
downloadaur-28ce6aea49dee8c3057c20f8150f6872dec199fb.tar.gz
Fix scripts/ permissions, add conflicts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7080ea900f79..0c0d7dc16349 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Owen Trigueros <owentrigueros@gmail.com>
pkgname=turtl-server-git
-pkgver=r209.f37f183
-pkgrel=2
+pkgver=r211.babccca
+pkgrel=1
pkgdesc="The secure, collaborative notebook's server"
arch=('any')
url="https://turtlapp.com/"
license=('AGPL')
depends=('nodejs' 'postgresql')
makedepends=('git' 'npm')
+conflicts=('turtl-server')
install=$pkgname.install
source=("$pkgname::git+https://github.com/turtl/server.git"
"turtl-server-git.install"
@@ -16,7 +17,7 @@ source=("$pkgname::git+https://github.com/turtl/server.git"
"turtl.sysusers")
md5sums=('SKIP'
- '2277c97e9f9ea821b35f5f4215e5ff9b'
+ '95e7cdde22d846c34334b7f61aa0980c'
'ef593935d035ae7df448dbb18aaed70f'
'c6727740e7165fa825bc011ec5f50f78')
@@ -42,7 +43,7 @@ package() {
find controllers/ -type f -exec install -Dm644 {} "$pkgdir"/usr/share/webapps/turtl/{} \;
find helpers/ -type f -exec install -Dm644 {} "$pkgdir"/usr/share/webapps/turtl/{} \;
find models/ -type f -exec install -Dm644 {} "$pkgdir"/usr/share/webapps/turtl/{} \;
- find scripts/ -type f -exec install -Dm644 {} "$pkgdir"/usr/share/webapps/turtl/{} \;
+ find scripts/ -type f -exec install -Dm755 {} "$pkgdir"/usr/share/webapps/turtl/{} \;
find tools/ -type f -exec install -Dm644 {} "$pkgdir"/usr/share/webapps/turtl/{} \;
find node_modules/ -type f -exec install -Dm644 {} "$pkgdir"/usr/share/webapps/turtl/{} \;
install -Dm644 server.js "$pkgdir"/usr/share/webapps/turtl/server.js