summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWalter Reiner2018-02-11 20:16:47 +0000
committerWalter Reiner2018-02-11 20:16:47 +0000
commit7559944bb68c5bc512d081bde2ad12df6890a783 (patch)
treed1a533c2369eddaacae1862828910dd19801634f /PKGBUILD
parent2d114c0f054a3e6d88bbe70d8bd147a54a47964f (diff)
downloadaur-7559944bb68c5bc512d081bde2ad12df6890a783.tar.gz
New version
Changed PKGBUILD to use new v0.3.2 Added install/upgrade notice to .install file for v0.3.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 19 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f32765bc3e5b..d6dc6e2ea233 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,31 @@
+#
+# Please note:
+# Export your keys using export_keys command in
+# trtl-simplewallet before upgrading to version
+# 0.3.2 (r135.7fcc6ad).
+#
+# For more information visit:
+# https://github.com/turtlecoin/turtlecoin/releases/tag/v0.3.2
+#
+
pkgname=turtlecoin-bin
-pkgver=v0.3.1
-pkgrel=2
+pkgver=v0.3.2
+pkgrel=1
pkgdesc="Turtlecoin simplewallet and miner"
arch=('x86_64')
url="https://turtlecoin.lol"
license=('LGPLv3')
install="${pkgname}.install"
conflicts=('turtlecoin-git')
-source=("https://github.com/turtlecoin/turtlecoin/releases/download/${pkgver}/TurtleCoin-${pkgver}-linux-staticboost-CLI.tar.gz")
-sha256sums=('98f95ac907c47eeff63949ec943afa3e04c7def91005bef4eade04bf1302e25d')
+source=("https://github.com/turtlecoin/turtlecoin/releases/download/${pkgver}/turtlecoin-${pkgver}-linux-staticboost.tar.gz")
+sha256sums=('e7c5224c578fcd0fc50f43d3f0b98b9af9536e0b1c94a1113acece65d7c37981')
package() {
# extract the tarball
- mkdir -p "TurtleCoin-${pkgver}-linux-staticboost-CLI" && tar xfz TurtleCoin-${pkgver}-linux-staticboost-CLI.tar.gz -C "TurtleCoin-${pkgver}-linux-staticboost-CLI"
+ mkdir -p "TurtleCoin-${pkgver}-linux-staticboost-CLI" && tar xfz turtlecoin-${pkgver}-linux-staticboost.tar.gz -C "TurtleCoin-${pkgver}-linux-staticboost-CLI"
- install -D -m755 "TurtleCoin-${pkgver}-linux-staticboost-CLI/miner" -T "$pkgdir/usr/bin/trtl-miner"
- install -D -m755 "TurtleCoin-${pkgver}-linux-staticboost-CLI/simplewallet" -T "$pkgdir/usr/bin/trtl-simplewallet"
- install -D -m755 "TurtleCoin-${pkgver}-linux-staticboost-CLI/TurtleCoind" -t "$pkgdir/usr/bin/"
- install -D -m755 "TurtleCoin-${pkgver}-linux-staticboost-CLI/walletd" -T "$pkgdir/usr/bin/trtl-walletd"
+ install -D -m755 "TurtleCoin-${pkgver}-linux-staticboost-CLI/turtlecoin-${pkgver}/miner" -T "$pkgdir/usr/bin/trtl-miner"
+ install -D -m755 "TurtleCoin-${pkgver}-linux-staticboost-CLI/turtlecoin-${pkgver}/simplewallet" -T "$pkgdir/usr/bin/trtl-simplewallet"
+ install -D -m755 "TurtleCoin-${pkgver}-linux-staticboost-CLI/turtlecoin-${pkgver}/TurtleCoind" -t "$pkgdir/usr/bin/"
+ install -D -m755 "TurtleCoin-${pkgver}-linux-staticboost-CLI/turtlecoin-${pkgver}/walletd" -T "$pkgdir/usr/bin/trtl-walletd"
}