summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2020-09-28 10:23:10 -0600
committerMark Wagie2020-09-28 10:23:10 -0600
commit3454bc9a7d2c80d67ec744821853954101e4d8b9 (patch)
tree6b8ef576e163b7ee39e145c160dc21465896e8e2 /PKGBUILD
parent7e6fcb67319dcd5400d4847b961fb47a65b96c2c (diff)
downloadaur-3454bc9a7d2c80d67ec744821853954101e4d8b9.tar.gz
rebuild using nodejs v14
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 3 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e329c862af3..1a9eab6804bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
# Contributor: ganthern <https://github.com/ganthern>
pkgname=tutanota-desktop
pkgver=3.76.10
-pkgrel=1
+pkgrel=2
pkgdesc="Official Tutanota email client"
arch=('x86_64')
url="https://tutanota.com"
license=('GPL3')
depends=('nss' 'libxss' 'libxtst' 'libappindicator-gtk3' 'libnotify')
-makedepends=('npm' 'nvm')
+makedepends=('npm')
source=("https://github.com/tutao/tutanota/archive/tutanota-release-$pkgver.tar.gz"
"$pkgname"
"$pkgname.desktop")
@@ -18,22 +18,9 @@ sha256sums=('2d2ba3bb31048b0adae241fa4c07e2e52d486a40cc6326426009ebe6415d0a57'
'1215678e2fc23cfbeb73063f68dc440891e5b2e10734fa7f402e06860c292e31')
build() {
-
- # Use nodejs v12 until upstream fixes build with v14
- export npm_config_cache="$srcdir/npm-cache"
- local npm_prefix=$(npm config get prefix)
- local nodeversion='12.18.4'
- npm config delete prefix
- source /usr/share/nvm/init-nvm.sh
- nvm install "$nodeversion" && nvm use "$nodeversion"
-
cd "${pkgname%-*}-${pkgname%-*}-release-$pkgver"
- npm install
+ npm install --cache "$srcdir/npm-cache"
node dist -l --custom-desktop-release --unpacked
-
- # Restore node config from nvm
- npm config set prefix "$npm_prefix"
- nvm unalias default
}
package() {