summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2020-05-12 09:36:59 -0600
committerMark Wagie2020-05-12 09:36:59 -0600
commit46ee626c37e3b0bf77548b100900e735d8752338 (patch)
tree8addc96f671f4f07ff08282217f29d386144b27a /PKGBUILD
parent114ccd80b1ec90867862254477816b20c7325068 (diff)
downloadaur-46ee626c37e3b0bf77548b100900e735d8752338.tar.gz
updated to 3.73.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 16 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51a5a7075fb4..e03c1345db05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,39 +2,42 @@
# Co-Maintainer: Aaron J. Graves <linux@ajgraves.com>
# Contributor: ganthern <https://github.com/ganthern>
pkgname=tutanota-desktop
-pkgver=3.72.0
+pkgver=3.73.1
pkgrel=1
pkgdesc="Official Tutanota email client"
arch=('x86_64')
url="https://tutanota.com"
license=('GPL3')
depends=('nss' 'libxss' 'libxtst' 'libappindicator-gtk3' 'libnotify')
-makedepends=('npm')
+makedepends=('npm' 'nvm')
source=("https://github.com/tutao/tutanota/archive/tutanota-release-$pkgver.tar.gz"
- '1928.patch'
"$pkgname"
"$pkgname.desktop")
-sha256sums=('2d2fad61b85fec6398a4efaaf5aa23be3049fe632439ebaf01604ecc21662136'
- '614755f15fe792caf617829b19198d6a74b480436fea45568b315773c60a9ae6'
+sha256sums=('4d49b222667da949be083fdebe8184b9f9d304cac0abc16a83fcab49e0edffca'
'4f91e842bd92a3312943854383e4929f9baf6cb684a7027aa55edcce1bf4ca16'
'1215678e2fc23cfbeb73063f68dc440891e5b2e10734fa7f402e06860c292e31')
-prepare() {
- cd "${pkgname%-*}-${pkgname%-*}-release-$pkgver"
+build() {
- # add builds w/o auto-updates and unpacked builds, close #1857
- patch -p1 -i "$srcdir/1928.patch"
-}
+ # Use nodejs v10 until upstream fixes build with v14
+ export npm_config_cache="$srcdir/npm-cache"
+ npm config delete prefix
+ source /usr/share/nvm/init-nvm.sh
+ local npm_prefix=$(npm config get prefix)
+ local nodeversion='10.20.1'
+ nvm install "$nodeversion" && nvm use "$nodeversion"
-build() {
cd "${pkgname%-*}-${pkgname%-*}-release-$pkgver"
- npm install --cache "$srcdir/npm-cache"
+ npm install
node dist -l --custom-desktop-release --unpacked
+
+ # Restore node config from nvm
+ npm config set prefix "$npm_prefix"
+ nvm unalias default
}
package() {
cd "${pkgname%-*}-${pkgname%-*}-release-$pkgver"
-
install -d "$pkgdir/opt/$pkgname"
cp -r build/desktop/linux-unpacked/* \
"$pkgdir/opt/$pkgname"