summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-07-06 12:41:06 -0600
committerMark Wagie2021-07-06 12:41:06 -0600
commit671604d28123cf4c8bd43381524c95bdd9eeb6da (patch)
tree208af5eb386fffd35fc43925387b448e9414b55c /PKGBUILD
parentaa1ce311e1f58000f0a6aa25e5d3d3ad262f3d66 (diff)
downloadaur-671604d28123cf4c8bd43381524c95bdd9eeb6da.tar.gz
3.84.10
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 4 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 24396ace6a66..f2df018d4c3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,51 +2,25 @@
# Co-Maintainer: Aaron J. Graves <linux@ajgraves.com>
# Contributor: ganthern <https://github.com/ganthern>
pkgname=tutanota-desktop
-pkgver=3.84.7
-pkgrel=2
+pkgver=3.84.10
+pkgrel=1
pkgdesc="Official Tutanota email client"
arch=('x86_64')
url="https://tutanota.com"
license=('GPL3')
depends=('nss' 'libappindicator-gtk3' 'libnotify' 'org.freedesktop.secrets')
-makedepends=('npm' 'nvm')
+makedepends=('npm')
source=("https://github.com/tutao/tutanota/archive/tutanota-release-$pkgver.tar.gz"
"$pkgname"
"$pkgname.desktop")
-sha256sums=('8d039b884a8ea1ebfac293bb5b2569f4d6b74b457b09ff936c325455e2650f62'
+sha256sums=('b7a1e1652addb94c4b41f3868989fcea39c72851c03a8be4a4f708f8ad5ec6b3'
'4f91e842bd92a3312943854383e4929f9baf6cb684a7027aa55edcce1bf4ca16'
'a2e2b932eb0bc2ad2413b7f39eb9fbdb517f5670367413f76d718d5d270996f7')
-_ensure_local_nvm() {
- # lets be sure we are starting clean
- which nvm >/dev/null 2>&1 && nvm deactivate && nvm unload
- export NVM_DIR="$srcdir/.nvm"
-
- # The init script returns 3 if version
- # specified in ./.nvrc is not (yet) installed in $NVM_DIR
- # but nvm itself still gets loaded ok
- source /usr/share/nvm/init-nvm.sh || [[ $? != 1 ]]
-}
-
-prepare() {
- # Use Node.js 14 per upstream
- export npm_config_cache="$srcdir/npm-cache"
- local npm_prefix=$(npm config get prefix)
- local nodeversion='14.17.2'
- npm config delete prefix
- _ensure_local_nvm
- nvm install "$nodeversion" && nvm use "$nodeversion"
-}
-
build() {
cd "${pkgname%-*}-${pkgname%-*}-release-$pkgver"
- _ensure_local_nvm
npm install
node dist -l --custom-desktop-release --unpacked
-
- # Restore node config from nvm
- npm config set prefix "$npm_prefix"
- nvm unalias default
}
package() {