summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTest User2020-04-15 08:51:11 -0600
committerTest User2020-04-15 08:51:11 -0600
commit95771c0d0a62154a4ad26a59b0b882d0acbc05c7 (patch)
tree060e77338a73a57cdea2d8a0c0dff9f32623eed8 /PKGBUILD
parent5d278456db62463792ccb41fa992c717607f627b (diff)
downloadaur-95771c0d0a62154a4ad26a59b0b882d0acbc05c7.tar.gz
updated to 3.71.4, add patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e908eb5b7639..343a8c1d1eb5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Co-Maintainer: Aaron J. Graves <linux@ajgraves.com>
+# Contributor: ganthern <https://github.com/ganthern>
pkgname=tutanota-desktop
-pkgver=3.70.1
+pkgver=3.71.4
pkgrel=1
pkgdesc="Official Tutanota email client"
arch=('x86_64')
@@ -10,34 +11,32 @@ license=('GPL3')
depends=('nss' 'libxss' 'libxtst' 'libappindicator-gtk3' 'libnotify')
makedepends=('npm')
source=("https://github.com/tutao/tutanota/archive/tutanota-release-$pkgver.tar.gz"
+ '1928.patch'
"$pkgname"
"$pkgname.desktop")
-sha256sums=('37cc07bb49836e58ab9e72067fff9e48da48eeecd4ce216dc464f8ae6761f74d'
+sha256sums=('e4fbf7a8876433dc1ffdd9e24d6dc980e7b2ff2e4da389169aec72588babd41e'
+ '614755f15fe792caf617829b19198d6a74b480436fea45568b315773c60a9ae6'
'4f91e842bd92a3312943854383e4929f9baf6cb684a7027aa55edcce1bf4ca16'
'1215678e2fc23cfbeb73063f68dc440891e5b2e10734fa7f402e06860c292e31')
prepare() {
cd "${pkgname%-*}-${pkgname%-*}-release-$pkgver"
- # Change target to dir instead of AppImage
- sed -i 's/"target": "AppImage"/"target": "dir"/g' \
- buildSrc/electron-package-json-template.js
-
- # Disable removing distDir
- sed -i '65d' buildSrc/DesktopBuilder.js
+ # add builds w/o auto-updates and unpacked builds, close #1857
+ patch -p1 -i "$srcdir/1928.patch"
}
build() {
cd "${pkgname%-*}-${pkgname%-*}-release-$pkgver"
npm install --cache "$srcdir/npm-cache"
- node dist -l prod
+ node dist -l --custom-desktop-release --unpacked
}
package() {
cd "${pkgname%-*}-${pkgname%-*}-release-$pkgver"
install -d "$pkgdir/opt/$pkgname"
- cp -r build/dist/installers/linux-unpacked/* \
+ cp -r build/desktop/linux-unpacked/* \
"$pkgdir/opt/$pkgname"
install -Dm755 "$srcdir/$pkgname" -t "$pkgdir/usr/bin"