summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFredy García2021-09-19 15:12:28 -0500
committerFredy García2021-09-19 15:12:28 -0500
commit08428f5b59ea7519e062e6b3133736a81ec2b5fb (patch)
treee12ffb65b086cec30b8c782ec16ef56367ccb2f8 /PKGBUILD
parent5fbe43dcaabdddce09a3388d99a42bdcef8ee4f2 (diff)
downloadaur-tuxmath.tar.gz
Adding rename-blits-to-tmblits patch.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fe2e92202ba2..727c230b28d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,33 +8,34 @@
pkgname=tuxmath
pkgver=2.0.3
-pkgrel=5
+pkgrel=6
pkgdesc="An educational math tutorial game starring Tux, the Linux Penguin"
arch=("i686" "x86_64")
url="https://github.com/tux4kids/${pkgname}/"
license=("custom:OFL" "GPL")
depends=("t4kcommon")
-makedepends=("gcc9")
options=(!docs)
source=(
"${pkgname}-${pkgver}.tar.gz::https://github.com/tux4kids/${pkgname}/archive/upstream/${pkgver}.tar.gz"
- "menu_lan.patch"
+ "0001-src-menu_lan.c-Remove-unused-duplicate-lan_player_in.patch"
+ "0002-rename-blits-to-tmblits.patch"
)
sha256sums=(
"ab91bd6df17eb9377e5608701030bd32110a3588933bf0e4c26b5697fb2a4698"
- "f6dad4cb620bf11ad9608dd95190ae6cafc78f0345fd92d8fb43a2a427dbb0df"
+ "852f82370e323ea34825864c063bd44a5dbd6dd60fb2c52338edbeb0b70fbafe"
+ "b5ede8e1a870cd19010890d8ca1867c8eae86c9dc3b78712c44e5e7576c05b91"
)
prepare() {
cd "${srcdir}/${pkgname}-upstream-${pkgver}"
- patch -Np1 -i "${srcdir}/menu_lan.patch"
+ patch -Np1 -i "${srcdir}/0001-src-menu_lan.c-Remove-unused-duplicate-lan_player_in.patch"
+ patch -Np1 -i "${srcdir}/0002-rename-blits-to-tmblits.patch"
}
build() {
cd "${srcdir}/${pkgname}-upstream-${pkgver}"
- export CC=/usr/bin/gcc-9
./configure \
--prefix=/usr \
--localstatedir=/usr/share/games \