summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoreugene2024-01-30 17:59:40 +0000
committereugene2024-01-30 17:59:40 +0000
commitebb24e69a02f0a3e445a1da1f6fb68db4236f619 (patch)
tree1a3cb17ea6f5bfcc33caf8391ce5ebc3fd371602 /PKGBUILD
parented16ab0f31a27d6813748ddf81eb1cd7bdea6401 (diff)
downloadaur-ebb24e69a02f0a3e445a1da1f6fb68db4236f619.tar.gz
update build script
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 12 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5df3d84ee97a..a288006e3acd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,14 +11,15 @@ arch=('x86_64')
url='https://tuxpaint.org/'
license=('GPL-2.0-only')
backup=('etc/tuxpaint/tuxpaint.conf')
-depends=('glibc' 'cairo' 'gdk-pixbuf2' 'zlib' 'fontconfig' 'libpng' 'pango'
- 'glib2' 'freetype2' 'harfbuzz' 'fribidi' 'libpaper' 'librsvg' 'libimagequant'
+depends=('glibc' 'cairo' 'zlib' 'fontconfig' 'libpng' 'pango'
+ 'glib2' 'fribidi' 'libpaper' 'librsvg' 'libimagequant' 'hicolor-icon-theme'
'sdl2' 'sdl2_image' 'sdl2_gfx' 'sdl2_mixer' 'sdl2_pango' 'sdl2_ttf')
-makedepends=('gperf' 'setconf' 'imagemagick')
+makedepends=('gperf' 'imagemagick')
optdepends=('tuxpaint-stamps: more stamps'
'tuxpaint-config: configuration manager'
'python2: zh_tw font generator script'
- 'bash: for tp-magic-config, zh_tw doc generstor, tuxpaint-import scripts')
+ 'fontforge: zh_tw doc generstor script'
+ 'bash: for tp-magic-config, tuxpaint-import, zh_tw doc generator scripts')
source=("https://downloads.sourceforge.net/sourceforge/tuxpaint/$pkgname-$pkgver.tar.gz")
sha256sums=('09cce22241481dc1360fc4bc5d4da1d31815d7a2563b9e9fa217a672ba974bf2')
@@ -29,20 +30,13 @@ prepare() {
for f in docs/outdated/zh_tw/mkTuxpaintIM.py fonts/locale/zh_tw_docs/maketuxfont.py; do
sed -i '0,/python$/s//python2/' $f
done
-
- # native fullscreen by default
- setconf -u src/tuxpaint.conf fullscreen=yes
- setconf -u src/tuxpaint.conf native=yes
-
- # location of bash completion files
- setconf Makefile COMPLETIONDIR='$(DESTDIR)/usr/share/bash-completion/completions'
-
- # no KDE4-related requirements at installation-time
- setconf Makefile ARCH_INSTALL='install-man install-importscript install-bash-completion'
}
build() {
- make -C "$pkgname-$pkgver" PREFIX=/usr clean translations all -j1
+ make -C "$pkgname-$pkgver" PREFIX=/usr \
+ LDFLAGS="$LDFLAGS" \
+ OPTFLAGS="$CFLAGS -ffast-math" FASTMATH="$CFLAGS -ffast-math" \
+ all
}
package() {
@@ -50,8 +44,10 @@ package() {
PREFIX=/usr \
GNOME_PREFIX=/usr \
X11_ICON_PREFIX="$pkgdir/usr/share/pixmaps" \
+ COMPLETIONDIR="$pkgdir/usr/share/bash-completion/completions" \
DESTDIR="$pkgdir" \
- install -j1
+ PACKAGE_ONLY=yes \
+ install
# bash completions
mv "$pkgdir/usr/share/bash-completion/completions/tuxpaint-completion.bash" \
@@ -60,10 +56,6 @@ package() {
# docs
mv "$pkgdir/usr/share/doc/$pkgname-$pkgver" \
"$pkgdir/usr/share/doc/$pkgname"
-
- # desktop shortcut
- install -Dm644 "$pkgname-$pkgver/src/$pkgname.desktop" \
- "$pkgdir/usr/share/applications/$pkgname.desktop"
}
# getver: tuxpaint.org/download/source