summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122021-06-22 17:12:58 +0200
committerwillemw122021-06-22 17:12:58 +0200
commit50c3d11aa8bf07a30a372cc59ddea5aa1a232a85 (patch)
tree0f61d462a8e4682ca00fe8a6e98e8bd9f6fab8e2 /PKGBUILD
parent83df7611167c0b3746bf2d77852c8092bf61a126 (diff)
downloadaur-50c3d11aa8bf07a30a372cc59ddea5aa1a232a85.tar.gz
Patch for missing search_providers
Cleanup (depends, ...)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d3fced26377..92f61b303437 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,37 @@
# Maintainer: willemw <willemw12@gmail.com>
-_pkgname=tv-overlord
-pkgname=$_pkgname-git
-pkgver=r423.c62af1d
+pkgname=tv-overlord-git
+pkgver=r446.f394059
pkgrel=1
-pkgdesc="Download and manage tv shows"
+pkgdesc="Download and manage TV shows"
+arch=('any')
url="https://bitbucket.org/tvoverlord/tv-overlord"
license=('GPL')
-arch=('any')
-depends=('python-beautifulsoup4' 'python-click' 'python-colorama' 'python-dateutil'
- #'python-feedparser' 'python-tvdb_api' 'python-requests')
- 'python-feedparser' 'python-tvdb_api-git' 'python-requests')
+depends=('python-beautifulsoup4' 'python-click' 'python-colorama' 'python-dateutil' 'python-feedparser' 'python-tvdb_api')
makedepends=('git' 'python-setuptools')
optdepends=('deluge: torrent client' 'transmission-cli: torrent client')
-source=($_pkgname::git+https://bitbucket.org/tvoverlord/tv-overlord.git)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=($pkgname::git+$url.git)
md5sums=('SKIP')
pkgver() {
- cd $_pkgname
+ cd $pkgname
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd $pkgname
+ sed -i "s|'tvoverlord/search_providers'.*||" setup.py
+}
+
build() {
- cd $_pkgname
+ cd $pkgname
python setup.py build
}
package() {
- cd $_pkgname
+ cd $pkgname
python setup.py install --root="$pkgdir/" --optimize=1
}