summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLinArcX2017-03-24 01:26:55 +0430
committerLinArcX2017-03-24 01:26:55 +0430
commit0096c6fbebc1bf56bdfa4c8a15eaed77dda1f1db (patch)
tree7aa4a509caff563aa0a2332bc738c6d4a9e2a5e1 /PKGBUILD
downloadaur-0096c6fbebc1bf56bdfa4c8a15eaed77dda1f1db.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3dfcfcd76567
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: LinArcX <linarcx@gmail.com>
+
+pkgname=tvdb3_api-git
+pkgver=0.1
+pkgrel=1
+pkgdesc="easy to use interface to thetvdb.com(Python3)"
+arch=('any')
+url="https://github.com/dbr/tvdb_api"
+license=('GPL')
+depends=('python')
+makedepends=('git' 'python-setuptools')
+provides=($pkgname)
+conflicts=($pkgname)
+source=($_pkgname::git://github.com/dbr/tvdb_api.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $pkgname
+ python setup.py build
+}
+
+package() {
+ cd $pkgname
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+