summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Mekkering2016-06-15 14:23:39 +0200
committerAlex Mekkering2016-06-15 14:23:39 +0200
commit408b0651e2f5faf78ddc7dc741a48f89138a0891 (patch)
tree787bd9477140842634a8e93c51044a9a8301a872 /PKGBUILD
parent05aefeea2c365be7860cc2014aa4ce7faf10d6c9 (diff)
downloadaur-408b0651e2f5faf78ddc7dc741a48f89138a0891.tar.gz
updated architectures, dependencies and conflicts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f7515a6e9a94..742a94b9d46c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,17 @@
pkgname=tvheadend
pkgver=4.0.9
-pkgrel=2
+pkgrel=3
pkgdesc="TV streaming server for Linux"
-arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://tvheadend.org/projects/tvheadend"
license=('GPL3')
-depends=('avahi' 'linuxtv-dvb-apps' 'openssl' 'python2' 'ffmpeg2.8' 'uriparser')
-makedepends=('git' 'wget')
-optdepends=('xmltv: For an alternative source of programme listings')
+depends=('avahi' 'linuxtv-dvb-apps' 'ffmpeg2.8' 'uriparser')
+makedepends=('git' 'wget' 'python2')
+optdepends=('xmltv: For an alternative source of programme listings'
+ 'libiconv: For conversion of character encodings')
provides=('tvheadend')
-conflicts=('tvheadend' 'hts-tvheadend' 'hts-tvheadend-svn' 'hts-tvheadend-git' 'tvheadend-git')
+conflicts=('tvheadend-git')
install=tvheadend.install
source=("https://github.com/tvheadend/tvheadend/archive/v$pkgver.tar.gz"
@@ -25,10 +26,9 @@ sha512sums=('ba8c6edcef126c6a260a9251b0948747074061c8f16fb20f03b250c6698645172c9
'166985b311e1e004afed53af1fdd58b0f29f3fd09af367abca270f94564f5f821027e60220f9e588a8895939eae360e99947f45b863fbbc0b541c99389d82bad')
prepare() {
- export PKG_CONFIG_PATH=/usr/lib/ffmpeg2.8/pkgconfig
cd ${srcdir}/${pkgname}-${pkgver}
- patch -p1 < ../tvheadend-4.0.9-1.patch
- ./configure --prefix=/usr --python=python2
+ patch -p1 -i ../tvheadend-4.0.9-1.patch
+ env PKG_CONFIG_PATH=/usr/lib/ffmpeg2.8/pkgconfig ./configure --prefix=/usr --python=python2
}
build() {