summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan Ziemba2016-03-14 00:06:36 -0400
committerDan Ziemba2016-03-14 00:06:36 -0400
commit0bc82ba17e27f16fbd24532b4b76978403289992 (patch)
treec95f797308cd1f4ac8347c32f5a759a5e07ebd41 /PKGBUILD
parentdffe6e91466bd28d27c8341ed2539106f29bd0f0 (diff)
downloadaur-0bc82ba17e27f16fbd24532b4b76978403289992.tar.gz
Fixed deps to depend on all external libs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23f09cf8b995..79d89c66a622 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,9 @@
# Maintainer: Dan Ziemba <zman0900@gmail.com>
# Contributor: Benjamin Hedrich <kiwisauce (a) pagenotfound (dot) de>
+# To enable hdhomerun, add 'libhdhomerun' to depends and '--enable-hdhomerun_client' to
+# the configure command in build().
+
pkgname=tvheadend-git
_gitname='tvheadend-git'
pkgver=4.1.r1672.g3927788
@@ -29,7 +32,12 @@ pkgver() {
build() {
cd "${srcdir}/${_gitname}"
- ./configure --prefix=/usr --mandir=/usr/share/man/man1 --python=python2 --release
+ ./configure --prefix=/usr --mandir=/usr/share/man/man1 --python=python2 --release \
+ --disable-libffmpeg_static --disable-libx264_static \
+ --disable-libx265_static --enable-libx265 \
+ --enable-vdpau --enable-nvenc \
+ --disable-libmfx_static --enable-libmfx \
+ --disable-hdhomerun_static
make
}