summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan Ziemba2016-03-14 00:24:23 -0400
committerDan Ziemba2016-03-14 00:24:23 -0400
commit27e6342d054a7380a929ed17c9b13aeaf0181405 (patch)
treeedcb329b382f501e349c827fc45717a5971bfe6a /PKGBUILD
parent4ff169d98ce7f52e6e91fbca2e3c993630802666 (diff)
downloadaur-27e6342d054a7380a929ed17c9b13aeaf0181405.tar.gz
Include dvb-scan-tables as source
Instead of allowing build to pull a clean copy every time.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 12 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79d89c66a622..f122472d5107 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=tvheadend-git
_gitname='tvheadend-git'
pkgver=4.1.r1672.g3927788
-pkgrel=1
+pkgrel=2
pkgdesc="TV streaming server for Linux"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url="https://tvheadend.org/"
@@ -20,9 +20,11 @@ conflicts=('tvheadend' 'hts-tvheadend' 'hts-tvheadend-svn' 'tvheadend-git')
install=tvheadend.install
source=("${_gitname}::git+https://github.com/tvheadend/tvheadend.git#branch=master"
- 'tvheadend.service')
+ "dvb-scan-tables::git+https://github.com/tvheadend/dtv-scan-tables.git#branch=tvheadend"
+ 'tvheadend.service')
md5sums=('SKIP'
+ 'SKIP'
'b546f4486f0d28bea13ad1fb676acb27')
pkgver() {
@@ -30,6 +32,14 @@ pkgver() {
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "${srcdir}"
+ _dvbscan="${_gitname}/data/dvb-scan"
+ cp -a "dvb-scan-tables" "${_dvbscan}"
+ rm -rf "${_dvbscan}/.git"
+ touch "${_dvbscan}/.stamp"
+}
+
build() {
cd "${srcdir}/${_gitname}"
./configure --prefix=/usr --mandir=/usr/share/man/man1 --python=python2 --release \