summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan Ziemba2016-04-06 13:36:47 -0400
committerDan Ziemba2016-04-06 13:36:47 -0400
commit3d3ea9b8123582eca6f19ebff3d60495562ec31a (patch)
tree1395a67529fbc5e71a2fdc54f4cc0aac231c7407 /PKGBUILD
parente3ef209b82919197dab8d9d3d2522e092d2a28e0 (diff)
downloadaur-3d3ea9b8123582eca6f19ebff3d60495562ec31a.tar.gz
Build with python 3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 4 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7532751ac497..21afecae0cce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,14 @@
pkgname=tvheadend-git
_gitname='tvheadend-git'
-pkgver=4.1.r1817.gfc6b8ce
+pkgver=4.1.r1830.g596f711
pkgrel=1
pkgdesc="TV streaming server for Linux"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
url="https://tvheadend.org/"
license=('GPL3')
depends=('avahi' 'openssl' 'uriparser' 'ffmpeg' 'linuxtv-dvb-apps')
-makedepends=('git' 'python2')
+makedepends=('git' 'python')
optdepends=('xmltv: For an alternative source of programme listings')
provides=('tvheadend')
conflicts=('tvheadend' 'hts-tvheadend' 'hts-tvheadend-svn' 'tvheadend-git')
@@ -38,16 +38,12 @@ prepare() {
cp -a "dvb-scan-tables" "${_dvbscan}"
rm -rf "${_dvbscan}/.git"
touch "${_dvbscan}/.stamp"
-
- # See: https://tvheadend.org/issues/3696
- sed -i 's|/usr/bin/env python|/usr/bin/env python2|g' \
- "${_gitname}/support/doc/md_to_c.py"
}
build() {
cd "${srcdir}/${_gitname}"
./configure --prefix=/usr --mandir=/usr/share/man/man1 --release \
- --python=python2 \
+ --python=python3 \
--disable-ffmpeg_static --enable-libav \
--disable-libx264_static --enable-libx264 \
--disable-libx265_static --enable-libx265 \
@@ -58,7 +54,7 @@ build() {
--disable-libmfx_static --disable-qsv \
--disable-nvenc \
--disable-hdhomerun_static
- make
+ PYTHONIOENCODING="UTF-8" make
}
package() {