summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan Ziemba2018-05-31 21:20:36 -0400
committerDan Ziemba2018-05-31 21:20:36 -0400
commita213efa63419d88788318876720838715fc473da (patch)
tree154ae9e2c065d8dc364908c8bded753e7d867ef3 /PKGBUILD
parent472912d01743495c10fe3a25bbaec3cfa23666ac (diff)
downloadaur-a213efa63419d88788318876720838715fc473da.tar.gz
Fixed build with external ffmpeg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4aa947bbf3ed..cb5fc9cee03c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
pkgname=tvheadend-git
_gitname='tvheadend-git'
pkgver=4.3.r1252.g595fd174f
-pkgrel=2
+pkgrel=3
pkgdesc="TV streaming server for Linux"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://tvheadend.org/"
@@ -24,9 +24,11 @@ install=tvheadend.install
backup=('etc/conf.d/tvheadend')
source=("${_gitname}::git+https://github.com/tvheadend/tvheadend.git#branch=master"
- "dvb-scan-tables::git+https://github.com/tvheadend/dtv-scan-tables.git#branch=tvheadend")
+ 'dvb-scan-tables::git+https://github.com/tvheadend/dtv-scan-tables.git#branch=tvheadend'
+ 'fix-ffmpeg.patch')
md5sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ '2caa4893574ebb6c7f672e2313df865b')
pkgver() {
cd "${srcdir}/${_gitname}"
@@ -40,6 +42,10 @@ prepare() {
cp -a "dvb-scan-tables" "${_dvbscan}"
rm -rf "${_dvbscan}/.git"
touch "${_dvbscan}/.stamp"
+
+ # Fix changed constant name in ffmpeg
+ cd "${srcdir}/${_gitname}"
+ patch -p1 -i "${srcdir}/fix-ffmpeg.patch"
}
build() {