summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan Ziemba2016-04-22 20:45:57 -0400
committerDan Ziemba2016-04-22 20:45:57 -0400
commitfe486eda276a8fd46adc8b5a1c7d19ead73c77b6 (patch)
treead2a0e6e269f33e9cc2d260f9ad2c204bfc5f749 /PKGBUILD
parent001a8638053c86d324e0e66db9861836774a3ad2 (diff)
downloadaur-fe486eda276a8fd46adc8b5a1c7d19ead73c77b6.tar.gz
Now using tvh provided systemd service file.
You can now configure arguments in /etc/conf.d/tvheadend.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4098ed7dc352..6789447b6502 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=tvheadend-git
_gitname='tvheadend-git'
-pkgver=4.1.r1834.g957b835
+pkgver=4.1.r1931.gc3eefc6
pkgrel=1
pkgdesc="TV streaming server for Linux"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
@@ -18,14 +18,12 @@ optdepends=('xmltv: For an alternative source of programme listings')
provides=('tvheadend')
conflicts=('tvheadend' 'hts-tvheadend' 'hts-tvheadend-svn' 'tvheadend-git')
install=tvheadend.install
+backup=('etc/conf.d/tvheadend')
source=("${_gitname}::git+https://github.com/tvheadend/tvheadend.git#branch=master"
- "dvb-scan-tables::git+https://github.com/tvheadend/dtv-scan-tables.git#branch=tvheadend"
- 'tvheadend.service')
-
+ "dvb-scan-tables::git+https://github.com/tvheadend/dtv-scan-tables.git#branch=tvheadend")
md5sums=('SKIP'
- 'SKIP'
- 'b546f4486f0d28bea13ad1fb676acb27')
+ 'SKIP')
pkgver() {
cd "${srcdir}/${_gitname}"
@@ -60,7 +58,17 @@ build() {
package() {
cd "${srcdir}/${_gitname}"
make DESTDIR="$pkgdir/" install
- install -D -m 644 "$srcdir/tvheadend.service" \
+
+ install -D -m 644 "${srcdir}/${_gitname}/rpm/tvheadend.service" \
"$pkgdir/usr/lib/systemd/system/tvheadend.service"
+ sed -i 's|/etc/sysconfig|/etc/conf.d|g' "$pkgdir/usr/lib/systemd/system/tvheadend.service"
+
+ install -d "$pkgdir/etc/conf.d"
+ cat << EOF > "$pkgdir/etc/conf.d/tvheadend"
+# Configuration file for the tvheadend service.
+
+MALLOC_ARENA_MAX=4
+OPTIONS="-u hts -g video -6 --http_port 9981 --htsp_port 9982"
+EOF
}