summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPete Alexandrou2017-04-10 23:05:47 +0800
committerPete Alexandrou2017-04-10 23:05:47 +0800
commit11bfebb10112c550cc29e5e5db3e3b16f564ef90 (patch)
tree08cb0d319853b874a202a85f32acfcacb915add3 /PKGBUILD
parent8a0a8da5a7b0b2532722d90339d7cc75e02dfafb (diff)
downloadaur-11bfebb10112c550cc29e5e5db3e3b16f564ef90.tar.gz
version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c166a17b2fb..77ec9792dbf6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,29 @@
# Maintainer: Pete Alexandrou (ozmartian) <pete@ozmartians.com>
pkgname=tvlinker
-pkgver=3.2.0
-pkgrel=2
-pkgdesc="TV show link scraper + downloader for tv-release.net with a modern PyQt5 GUI"
+pkgver=3.5.0
+pkgrel=1
+pkgdesc="TV show link scraper + downloader for tv-release.pw incl. debrid and dl manager services"
arch=('any')
license=('GPL3')
url="http://tvlinker.ozmartians.com"
source=(https://github.com/ozmartian/${pkgname}/archive/${pkgver}.tar.gz)
depends=('python-pyqt5' 'python-beautifulsoup4' 'python-lxml')
-makedepends=('git' 'sed' 'python-setuptools')
+makedepends=('python-setuptools')
provides=()
conflicts=()
-md5sums=('SKIP')
+md5sums=('56e25f51997c69174a5499bfafe73c29')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- sed -i "s/pypi/arch/" __init__.py
+ sed -i "s/pypi/arch/" "${pkgname}/__init__.py"
}
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py build
+ python3 setup.py build
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
python3 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- # install -Dm644 "data/desktop/tvlinker.desktop" "${pkgdir}/usr/share/applications/tvlinker.desktop"
- # install -Dm644 "data/icons/tvlinker.png" "${pkgdir}/usr/share/pixmaps/tvlinker.png"
}