summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederik Schwan2020-11-21 19:25:49 +0100
committerFrederik Schwan2020-11-21 19:25:49 +0100
commit0e589660b1ed545a69002165dc1acd49afb2c76a (patch)
treea788cfad042e1e1eef15ff79fac2ab5f390fbd1f /PKGBUILD
parente60f5d7e09eb9611f236b60058e3dd905f88c9f8 (diff)
downloadaur-0e589660b1ed545a69002165dc1acd49afb2c76a.tar.gz
upgpkg: twinkle 1.10.2-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD65
1 files changed, 30 insertions, 35 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 16b631ef994e..ae3d584b4467 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,45 @@
-# $Id: PKGBUILD 68598 2012-03-29 08:03:13Z arodseth $
-# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Frederik Schwan <freswa at archlinux dot org>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: Jeff Mickey <jeff@archlinux.org>
# Contributor: Alexander Baldeck <alexander@archlinux.org>
# Contributor: Federico Quagliata (quaqo) <quaqo@despammed.com>
# Contributor: Alexander Rødseth <rodseth@gmail.com>
pkgname=twinkle
-pkgver=1.4.2
-pkgrel=19
-pkgdesc="Softphone for voice over IP and IM communication using SIP"
-arch=('x86_64' 'i686')
-url="http://www.twinklephone.com/"
-license=('GPL')
-depends=('file' 'speex' 'boost-libs' 'libsndfile' 'qt3' 'libzrtpcpp' 'commoncpp2')
-makedepends=('pkg-config' 'boost' 'gendesk')
-source=("http://www.xs4all.nl/~mfnboer/$pkgname/download/$pkgname-$pkgver.tar.gz"
- twinkle-1.4.2-ccrtp.patch)
-md5sums=('d70c8972f296ffd998c7fb698774705b'
- '934f59ff60a8ae29a152feb8bf131ae2')
+pkgver=1.10.2
+pkgrel=1
+pkgdesc='Softphone for voice over IP and IM communication using SIP'
+arch=('x86_64')
+url='http://twinkle.dolezel.info/'
+license=('GPL2')
+depends=('ucommon' 'ccrtp' 'libxml2' 'libsndfile' 'imagemagick' 'readline'
+ 'qt5-base' 'qt5-declarative' 'alsa-lib' 'libzrtpcpp'
+ 'bcg729' 'speex' 'speexdsp')
+makedepends=('cmake' 'bison' 'flex' 'qt5-tools')
+source=("https://github.com/LubosD/twinkle/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz"
+ 'G729-API.patch')
+b2sums=('52cfa4f1d31b040db46edadccc43431d04fe71036821a1ef0c5b8803bf7ccf2fcd1d15a8340e583d049c588290a85c8ee07c6738adc599d164f7f606b2f34dc1'
+ 'e86166cc48c46697f5b20bdc3fbd169dcb07214aa47d030d554fe7bd10e79748f88ca2a4a1ce359ba879c1edfe63ffed10cbba9c11b04f6171b491e14b67189c')
prepare() {
-# gendesk
- cd "$pkgname-$pkgver"
- patch -p1 -i "$srcdir"/twinkle-1.4.2-ccrtp.patch
+ cd ${pkgname}-${pkgver}
+ patch -Np1 < "${srcdir}"/G729-API.patch
}
build() {
- cd "$pkgname-$pkgver"
- autoreconf -fi
- export QTDIR=/usr/lib/qt3
- export PATH=$QTDIR/bin:$PATH
- CPPFLAGS="$CPPFLAGS -I/usr/include/qt3 -I/usr/include/libzrtpcpp" \
- ./configure --prefix=/usr \
- --without-kde \
- --with-speex \
- --without-ilbc \
- --mandir=/usr/share/man
- make
+ cd ${pkgname}-${pkgver}
+ cmake -B build -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DWITH_QT5=On \
+ -DWITH_DBUS=On \
+ -DWITH_ALSA=On \
+ -DWITH_ZRTP=On \
+ -DWITH_G729=On \
+ -DWITH_SPEEX=On
+ make -C build
}
package() {
- cd "$pkgname-$pkgver"
-
- make DESTDIR="$pkgdir" install
- install -Dm644 "$pkgdir/usr/share/twinkle/twinkle48.png" \
- "$pkgdir/usr/share/pixmaps/twinkle.png"
- install -Dm644 twinkle.desktop \
- "$pkgdir/usr/share/applications/twinkle.desktop"
+ cd ${pkgname}-${pkgver}
+ make -C build DESTDIR="${pkgdir}" install
}