summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraxzxc12362021-01-01 10:39:59 +0800
committeraxzxc12362021-01-01 10:39:59 +0800
commit3d375e80adbcfce98aefda671beb2e469629fefe (patch)
tree597e0f11262745c229ab57b24c0bc59f69ff85e8 /PKGBUILD
downloadaur-3d375e80adbcfce98aefda671beb2e469629fefe.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..bb1e4b5affeb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: axzxc1236 <axzxc1236 [(@>>] users.noreply.github.com>
+pkgname=twitch-dl-bin
+pkgver=1.13.1
+pkgrel=1
+pkgdesc="Twitch video downloader that use multiple concurrent connections"
+arch=(any)
+url="https://github.com/ihabunek/twitch-dl"
+license=('GPL3')
+depends=('python')
+provides=('twitch-dl' 'twitch-dl-bin')
+conflicts=('twitch-dl' 'twitch-dl-bin')
+source=('twitch-dl::https://github.com/ihabunek/twitch-dl/releases/download/1.13.1/twitch-dl.1.13.1.pyz')
+sha256sums=('393ca46bcd2cca83d25ad33399204b3a1ecebc339c72cad80f6f1adb51976f4e')
+noextract=('twitch-dl')
+
+package() {
+ install -Dm644 "${srcdir}/twitch-dl" "${pkgdir}/usr/bin/twitch-dl"
+ chmod +x ${pkgdir}/usr/bin/twitch-dl
+} \ No newline at end of file