summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBasioMeusPuga2017-10-26 05:35:52 +0530
committerBasioMeusPuga2017-10-26 05:35:52 +0530
commit4dd7bdcc813461b400ae807dc697ff5d80e3327b (patch)
tree745155a87c99f6c3c1d8d685599d952c4d404e18 /PKGBUILD
parente4aa7aaafe1d7041c34ce14a66da604fd976fa3c (diff)
downloadaur-4dd7bdcc813461b400ae807dc697ff5d80e3327b.tar.gz
Update to allow packaging using python-setuptools
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb2e0afdbf1a..8d34408a04bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,16 @@
pkgname=twitchy-git
_pkgname=twitchy
pkgdesc="CLI livestreamer / streamlink wrapper for twitch.tv"
-pkgver=r134.5f514d2
+pkgver=r31.38f8c54
pkgrel=1
-arch=('i686' 'x86_64')
+arch=('any')
url="https://github.com/BasioMeusPuga/twitchy"
license=('GPL3')
provides=('twitchy')
conflicts=('twitchy')
-depends=('python' 'streamlink' 'python-requests')
+depends=('python' 'streamlink' 'python-requests' 'python-setuptools')
makedepends=('git')
-optdepends=('livestreamer: alternate backend')
-source=("git://github.com/basiomeuspuga/${_pkgname}.git")
+source=("git://github.com/basiomeuspuga/${_pkgname}.git#branch=v3")
md5sums=(SKIP)
pkgver() {
@@ -21,10 +20,12 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+build() {
+ cd "$srcdir/$_pkgname"
+ python setup.py build
+}
package() {
- mkdir -p ${pkgdir}/usr/share/twitchy/
-
- install -Dm 755 twitchy/alarm.mp3 $pkgdir/usr/share/twitchy/alarm.mp3
- install -Dm 755 twitchy/twitchy.py $pkgdir/usr/bin/twitchy
+ cd "$srcdir/$_pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1
}