summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgbr2021-04-12 15:19:28 -0300
committergbr2021-04-12 15:19:28 -0300
commitb40e2e2916fa94d679c596b204e357e4f7bfc621 (patch)
treec6fa7444d3675ad8620583f4d384aa00357369d3 /PKGBUILD
parent30ab4cbce24fb8b8b4e1ecf70771183e246bd346 (diff)
downloadaur-twittuh-git.tar.gz
pkgbuild: general cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 17 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a980fc75570b..29056771b15b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname=twittuh
pkgname=twittuh-git
pkgver=r100.e1bd11b
-pkgrel=1
-pkgdesc='Small Go program to make RSS/ATOM/JSON feeds from Twitter timelines'
+pkgrel=2
+pkgdesc='Make RSS, ATOM, or JSON feeds from Twitter timelines'
arch=('x86_64')
url='https://github.com/derat/twittuh'
license=('BSD')
@@ -14,28 +14,28 @@ sha256sums=('SKIP')
pkgver() {
cd "$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$_pkgname"
- go build \
- -o "$_pkgname" \
- -trimpath \
- -buildmode=pie \
- -mod=readonly \
- -modcacherw \
- -ldflags "-extldflags \"${LDFLAGS}\"" \
- .
+ cd "$_pkgname"
+ go build \
+ -o "$_pkgname" \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-extldflags \"${LDFLAGS}\"" \
+ .
}
check() {
- cd "$_pkgname"
- go test -v ./...
+ cd "$_pkgname"
+ go test -v ./...
}
package() {
- cd "$_pkgname"
- install -Dm755 $_pkgname "$pkgdir"/usr/bin/$_pkgname
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ cd "$_pkgname"
+ install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
}