summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormirkobrombin2021-06-25 14:52:04 +0200
committermirkobrombin2021-06-25 14:52:04 +0200
commit55d2586de569894409128765d0b891caa97cd5e9 (patch)
tree282b5ee15e5947a7cf981be3043e75c290176fa1 /PKGBUILD
downloadaur-55d2586de569894409128765d0b891caa97cd5e9.tar.gz
Release 1.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f4fe7d6c8c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintaner: Mirko Brombin <send@mirko.pm>
+# Contributor: Mirko Brombin <send@mirko.pm>
+
+pkgname=twitz
+pkgver=1.1.0
+pkgrel=1
+pkgdesc='A GTK Twitch client for Linux (Under development)'
+arch=('x86_64')
+url="https://github.com/mirkobrombin/Twitz"
+license=('GPL3')
+depends=('hicolor-icon-theme' 'dconf' 'python' 'libhandy' 'gtk3' 'python-gobject' 'webkit2gtk' 'gst-plugins-good' 'gst-plugins-base' 'gst-libav' 'youtube-dl', 'python-mpv', 'python-opengl')
+makedepends=('meson' 'ninja')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/mirkobrombin/Twitz/archive/${pkgver}.tar.gz")
+sha256sums=('c39f74e082a6bfcabc363914cf68130bb0e49a68725c024baa5e8297d9fd4467')
+
+build() {
+ cd "Twitz-${pkgver}"
+ meson --prefix='/usr' build
+ ninja -C build
+}
+
+package() {
+ cd "Twitz-${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C build install
+}