summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcyrozap2019-09-28 19:54:39 -0500
committercyrozap2019-09-28 19:54:39 -0500
commit3de80e9ceec9bf9623043214483f2a424bbbe7e7 (patch)
treee11808cbd3ba8780abd542644c089f4300505b8b /PKGBUILD
parent896b346668a4b6876041c6da4215908e651497f7 (diff)
downloadaur-3de80e9ceec9bf9623043214483f2a424bbbe7e7.tar.gz
Fix the build with newer GCC again
Replaced the patch file with a sed command to make the fix more future-proof.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbe8c755ba19..06edf63735ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_name=twmn
pkgname="${_name}-git"
-pkgver=187.80f4883
+pkgver=190.861a323
pkgrel=1
pkgdesc="A notification system for tiling window managers"
arch=('any')
@@ -14,10 +14,8 @@ provides=('notification-daemon')
depends=('qt5-base' 'qt5-x11extras' 'boost-libs>=1.46' 'libxext' 'libxkbcommon-x11')
makedepends=('git' 'pkg-config' 'boost>=1.46')
conflicts=('twmn')
-source=("${_name}::git+https://github.com/sboli/${_name}.git"
- 'werror-fix.patch')
-sha256sums=('SKIP'
- '65aad59c679620071433864329c00486bfdd7ec3ae70cb34f7bab14f1f5fd54d')
+source=("${_name}::git+https://github.com/sboli/${_name}.git")
+sha256sums=('SKIP')
pkgver() {
cd "${_name}"
@@ -26,7 +24,7 @@ pkgver() {
prepare() {
cd "${_name}"
- patch -p1 < "${srcdir}/werror-fix.patch"
+ sed -i 's/-Werror//g' twmnd/twmnd.pro
}
build() {