summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcyrozap2019-09-10 03:44:50 -0500
committercyrozap2019-09-10 03:44:50 -0500
commit896b346668a4b6876041c6da4215908e651497f7 (patch)
treecf387bff75748d524e8ec24816f8738ce0b77790 /PKGBUILD
parentdb3c096d63da143e36b7e59b617be2f30f8cd117 (diff)
downloadaur-896b346668a4b6876041c6da4215908e651497f7.tar.gz
Fix the build with newer GCC
Not bumping pkgrel because this only affects those who haven't already built the package and a rebuild isn't necessary.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 33709f31763c..bbe8c755ba19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,14 +14,21 @@ provides=('notification-daemon')
depends=('qt5-base' 'qt5-x11extras' 'boost-libs>=1.46' 'libxext' 'libxkbcommon-x11')
makedepends=('git' 'pkg-config' 'boost>=1.46')
conflicts=('twmn')
-source=("${_name}::git+https://github.com/sboli/${_name}.git")
-sha256sums=('SKIP')
+source=("${_name}::git+https://github.com/sboli/${_name}.git"
+ 'werror-fix.patch')
+sha256sums=('SKIP'
+ '65aad59c679620071433864329c00486bfdd7ec3ae70cb34f7bab14f1f5fd54d')
pkgver() {
cd "${_name}"
echo "$(git rev-list --count HEAD).$(git describe --always )"
}
+prepare() {
+ cd "${_name}"
+ patch -p1 < "${srcdir}/werror-fix.patch"
+}
+
build() {
cd "${_name}"
qmake-qt5