summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12021-08-21 16:36:13 +0800
committerChocobo12021-08-21 16:42:32 +0800
commit128418447422c0e710f90bfd5cab766eea563778 (patch)
tree35082bbea49776d9eab5b5646576ccffc0539989 /PKGBUILD
parentf6906dae3d3df5e9e5c3bfe0bd3bd653be816461 (diff)
downloadaur-128418447422c0e710f90bfd5cab766eea563778.tar.gz
upgpkg: twolame-git 0.4.0.r3.g8c47401-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 60726f93ff60..fdde6885df67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=twolame-git
-pkgver=0.3.13.r100.gfb60b2e
+pkgver=0.4.0.r3.g8c47401
pkgrel=1
pkgdesc="An optimised MPEG Audio Layer 2 (MP2) encoder"
arch=('i686' 'x86_64')
url="https://www.twolame.org/"
license=('LGPL2')
depends=('glibc' 'libsndfile')
-makedepends=('git')
+makedepends=('git' 'asciidoc' 'doxygen' 'xmlto')
provides=('twolame')
conflicts=('twolame')
options=('staticlibs')
@@ -16,6 +16,12 @@ source=("git+https://github.com/njh/twolame.git")
sha256sums=('SKIP')
+prepare() {
+ cd "twolame"
+
+ sed -i -e 's|doxygen.png|doxygen.svg|g' "doc/html/Makefile.am"
+}
+
pkgver() {
cd "twolame"
@@ -26,7 +32,9 @@ build() {
cd "twolame"
NOCONFIGURE=1 ./autogen.sh
- ./configure --prefix="/usr" --disable-maintainer-mode
+ ./configure \
+ --prefix="/usr" \
+ --enable-maintainer-mode
make
}