aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBen Alex2015-06-10 13:48:25 +1000
committerBen Alex2015-06-10 13:48:25 +1000
commite8db81d9cf4d6ac3ea00fbcf6381d82132ef8883 (patch)
tree77bcec7876e907f8eac94d9d0ecd21ddaac2f3c0 /PKGBUILD
downloadaur-e8db81d9cf4d6ac3ea00fbcf6381d82132ef8883.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..191c56e42def
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Ben Alex <ben.alex@acegi.com.au>
+
+# See https://github.com/benalexau/twstools-aur for AUR PKGBUILD history
+
+pkgname=twstools
+pkgver=0.4.3
+pkgrel=1
+pkgdesc='Command line tools around Interactive Brokers TWS API'
+arch=('any')
+url="https://github.com/rudimeier/twstools"
+license=('BSD')
+depends=('libtwsapi')
+source=('https://bitbucket.org/rudimeier/twstools/downloads/twstools-0.4.3.tar.gz')
+md5sums=('527f71d5def8359ffd5c7b4bc8a07547')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR="$pkgdir/" install
+}