summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorendaaman2017-04-03 23:12:11 +0900
committerendaaman2017-04-03 23:12:11 +0900
commite80ceebfe4b65dae9f8cb486f9f7db89f4abf66a (patch)
treeca27a0e8bd7a625f2db6c0300f739bcdbd81ad82 /PKGBUILD
downloadaur-e80ceebfe4b65dae9f8cb486f9f7db89f4abf66a.tar.gz
version 0.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74e89de3e5e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Ken Enda <buhibuhidog@gmail.com>
+
+pkgname=tym
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="A tiny term for minimalists"
+arch=('x86_64')
+url="https://github.com/endaaman/tym"
+license=('MIT')
+depends=( 'vte3' 'lua' )
+source=("https://github.com/endaaman/${pkgname}/releases/download/$pkgver/${pkgname}-$pkgver.tar.gz")
+sha1sums=('1c625f66b16d7e3743ee592f423593439c40eede')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}