summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonas Bögle2021-09-20 15:52:26 +0200
committerJonas Bögle2021-09-20 15:52:26 +0200
commitf7cca3366c085b297004508bea0cf18527531c50 (patch)
tree710e70fc1b193c54399908b59bed38e6a8c15c02 /PKGBUILD
parente760a7b71d0c6c93bce8efd82be47b940079ad2c (diff)
downloadaur-f7cca3366c085b297004508bea0cf18527531c50.tar.gz
Remove option to build with systems electron
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 0 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c73edc1c0b80..8eedbbee5bbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,14 +16,6 @@ optdepends=(
source=("https://typora.io/linux/$filename")
sha512sums=('08d385582b799dd6c64e27ee33c1e2ef3cf497bcab2d8c1f3402fa496d83fbd94418170ed8a38ba5d81ebb790f35eb8969d8f295ce9a4625108a0af1bd33940e')
-# Set the ELECTRON environment variable to "electron" to use the electron package instead of the shipped electron version.
-# Warning: this is experimental and will probably break typora.
-if [[ ! -z $ELECTRON ]]; then
- depends+=($ELECTRON)
- source+=(typora.js)
- sha512sums+=('8ce47de8b0d0ab4b0323ee4c19a4daaf313513700d8c191faab299bfa21aaba9b55cbcf945914103e5f53607228fec3411a83aea8007b192616ad845a3af5c98')
-fi
-
package() {
bsdtar -xf data.tar.xz -C "$pkgdir/"
rm -rf "$pkgdir/usr/share/lintian/"
@@ -32,13 +24,4 @@ package() {
chmod -R go-w "$pkgdir/usr/share/typora/resources/node_modules"
sed -i '/Change Log/d' "$pkgdir/usr/share/applications/typora.desktop"
find "$pkgdir" -type d -exec chmod 755 {} \;
-
- # Alternatively use the systems electron as described above.
- if [[ ! -z $ELECTRON ]]; then
- appdir="${pkgdir}/usr/share/typora"
- mv "${appdir}" tmp/
- mv tmp/resources/app "${appdir}"
- rm -rf tmp/
- install -Dm755 "typora.js" "${pkgdir}/usr/bin/typora"
- fi
}