summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAttenuation2018-11-13 21:02:34 +0800
committerAttenuation2018-11-13 21:02:34 +0800
commitbf5ea761f76d3e743434397ea3b88041a660682b (patch)
tree9c1cc2249e41cd4aa5b06cb9edb7777e1f2780ae /PKGBUILD
downloadaur-bf5ea761f76d3e743434397ea3b88041a660682b.tar.gz
add package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d848968a714e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Attenuation <ouyangjun1999@gmail.com>
+pkgname=tztail
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='tztail (TimeZoneTAIL) allows you to view logs in the timezone you want '
+arch=('x86_64')
+url='https://github.com/thecasualcoder/tztail'
+license=('MIT')
+makedepends=('rust')
+depends=()
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('5adebc8cbc19e933ed8088682a75dd1b5a96f0c3d0e6c1976f3875afc04e45ab')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 target/release/$pkgname "$pkgdir/usr/bin/$pkgname"
+} \ No newline at end of file