summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander Shpilkin2021-02-10 21:42:56 +0300
committerAlexander Shpilkin2021-02-10 21:42:56 +0300
commit3018a5352ab59003ad0e661dc80dd76cddba6df6 (patch)
tree6b889808fce96071ed820f58d3e874d178c6c914 /PKGBUILD
parent841077b764333d9ba12ed3eaaa244d66ce67dd25 (diff)
downloadaur-3018a5352ab59003ad0e661dc80dd76cddba6df6.tar.gz
Switch from tag name to tag hash
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9064305a9454..3d7eba0bafb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,6 +3,7 @@
pkgname=uacme
pkgver=1.7
+_pkgsha=2b84bc5c8fbcd3ade4acffa0c28062782d8e29a4 # git show-ref upstream/$pkgver
pkgrel=1
pkgdesc='An ACMEv2 client written in plain C with minimal dependencies'
arch=('i686' 'x86_64')
@@ -11,9 +12,9 @@ makedepends=('asciidoc' 'git' 'libev')
depends=('curl' 'gnutls')
optdepends=('libev: for ualpn')
license=('GPL3')
-source=("$pkgname-$pkgver::git+https://github.com/ndilieto/$pkgname.git#tag=upstream/$pkgver?signed")
+source=("$pkgname-$pkgver::git+https://github.com/ndilieto/$pkgname.git#tag=$_pkgsha?signed")
sha256sums=('SKIP')
-validpgpkeys=('243828049BB5F549446516E24142E3D6318A7874') # Nicola Di Lieto
+validpgpkeys=('243828049BB5F549446516E24142E3D6318A7874') # gpg --fetch-keys https://github.com/ndilieto.gpg
build() {
cd "$pkgname-$pkgver"