aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsteadfasterX2019-01-03 11:30:35 +0100
committersteadfasterX2019-01-03 12:05:09 +0100
commit3e291bbc4d5d8236020504e8ba6606730d09439b (patch)
tree26ad16ac36428b30e7ea450f56426ee220c27090 /PKGBUILD
downloadaur-3e291bbc4d5d8236020504e8ba6606730d09439b.tar.gz
squashed and merged from upstream
added .SRCINFO added maintainer, better description README updated bumped version fix stupid github markdown bumped version (after 1 year daily usage... yea 1.0) completed install guide fix: typo for ssmtp fix: when no ignore pkg specified archnews failed fix: cron get not executed due to wrong file perm fix: create log directory if it doesn't exist missing line first version of a real readme new release fix: omg.. the ignores had an effect for the checks only.. fix: typo prevented arch news exec fix/new: parsing the config before install/remove this gives high flexibility to change installation path, user etc fix: whole installation now clean adding post install and post remove fix: uau symlink new: initial version of package build initial version of gitignore Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd761e9fdb90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: steadfasterX <steadfasterX [at] gmail -dot- com>
+pkgname=uau
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="A little helper for installing Arch upgrades scheduled, respecting the recommended upgrade checks and doing all this non-interactively"
+arch=('any')
+url="https://github.com/steadfasterX/arch_uau"
+license=('LGPL3')
+depends=('aur-comment-fetcher-git' 'checkupdates+aur' 'sudo' 'pacman' 'python3-memoizedb')
+makedepends=('git')
+optdepends=('ssmtp: to provide the sendmail like mail command')
+backup=('etc/unattended-arch-upgrade.conf' 'etc/unattended-arch-upgrade.ignore')
+source=("https://github.com/steadfasterX/arch_$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('SKIP')
+BINFIX=usr/local/bin
+SUDOERS=etc/sudoers.d
+SYSD=etc/systemd/system
+MANDIR=usr/share/man
+MAN5DIR=${MANDIR}/man5
+MAN8DIR=${MANDIR}/man8
+MAN5PAGE=uau.5
+MAN8PAGE=uau.8
+USER=root
+GROUP=root
+install=${pkgname}.install
+
+package() {
+ cd "arch_$pkgname-$pkgver"
+
+ mkdir -p $pkgdir/etc/cron.d $pkgdir/${BINFIX} $pkgdir/$SYSD $pkgdir/$MAN5DIR $pkgdir/$MAN8DIR
+
+ install -d -m 0750 $pkgdir/${SUDOERS}
+ install -o ${USER} -g ${GROUP} -m 0700 conf/uau_sudo $pkgdir/${SUDOERS}/uau_sudo
+ install -o ${USER} -g ${GROUP} -m 0744 conf/unattended-arch-upgrade.conf $pkgdir/etc/unattended-arch-upgrade.conf
+ install -o ${USER} -g ${GROUP} -m 0744 conf/unattended-arch-upgrade.ignore $pkgdir/etc/unattended-arch-upgrade.ignore
+ install -o ${USER} -g ${GROUP} -m 0755 bin/* $pkgdir/${BINFIX}/
+ ln -sfv uau $pkgdir/${BINFIX}/unattended-upgrade
+ install -o ${USER} -g ${GROUP} -m 0755 conf/archnews_cron $pkgdir/etc/cron.d/archnews
+ install -o ${USER} -g ${GROUP} -m 0755 conf/unattended-arch-upgrade.service $pkgdir/${SYSD}/unattended-arch-upgrade.service
+ install -o ${USER} -g ${GROUP} -m 0755 conf/unattended-arch-upgrade.timer $pkgdir/${SYSD}/unattended-arch-upgrade.timer
+
+ install -m 0644 doc/${MAN5PAGE} $pkgdir/${MAN5DIR}/${MAN5PAGE}
+ install -m 0644 doc/${MAN8PAGE} $pkgdir/${MAN8DIR}/${MAN8PAGE}
+
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+ install -D -m644 ./LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+}
+