summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDoug Penner2020-10-21 20:32:57 -0700
committerDoug Penner2020-10-21 20:32:57 -0700
commit13b47a779f7f671747a9c027ccbfdef1a970fb09 (patch)
tree5699c559c02a2bdbeffaeca9d6deb26b86a5a78d /PKGBUILD
parent5f5001ff6e777011172d582c8d4101a86449745e (diff)
downloadaur-13b47a779f7f671747a9c027ccbfdef1a970fb09.tar.gz
added patch from https://github.com/greatscottgadgets/ubertooth/issues/408
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6b28aae1d43..1defe99ed5af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=ubertooth
pkgver=2018.12.R1
_pkgver=2018-12-R1
-pkgrel=5
+pkgrel=6
pkgdesc="Open source wireless development platform suitable for Bluetooth experimentation"
url="https://github.com/greatscottgadgets/ubertooth/"
arch=('x86_64' 'i686')
@@ -9,8 +9,13 @@ license=('GPL')
depends=('bluez-libs' 'libbtbb>=2018.12.R1' 'libusb' 'libpcap' 'python-numpy' 'python-pyusb')
optdepends=('qt5-declarative' 'python-pyside2')
makedepends=('cmake')
-source=("https://github.com/greatscottgadgets/ubertooth/releases/download/${_pkgver}/ubertooth-${_pkgver}.tar.xz")
-sha256sums=('0042daa79db0f4148a0255cdf05aa57006e23ac36edf7024e9e99ccc4892867b')
+source=("https://github.com/greatscottgadgets/ubertooth/releases/download/${_pkgver}/ubertooth-${_pkgver}.tar.xz" "extern-packet_counter_max.patch")
+sha256sums=('0042daa79db0f4148a0255cdf05aa57006e23ac36edf7024e9e99ccc4892867b' '6a88a2e000e02b1dd31dee125cbe9f8713c2c397023ae9ee8f6e57aa71fa9598')
+
+prepare() {
+ cd "${pkgname}-${_pkgver}"
+ patch --forward --strip=1 --input="${srcdir}/extern-packet_counter_max.patch"
+}
build() {
cd "${srcdir}/${pkgname}-${_pkgver}/host/"