summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDoug Penner2019-03-05 19:12:59 -0800
committerDoug Penner2019-03-05 19:15:33 -0800
commita042c9b28c5e4ec5c03a2f286218c97ec60366b6 (patch)
tree011b1acc50b88e1e29b04edd98a46684aee57643 /PKGBUILD
parentbc9f1a666f5e5b0e487fa487a5ddab2a73104674 (diff)
downloadaur-a042c9b28c5e4ec5c03a2f286218c97ec60366b6.tar.gz
updated to 2018-12-R1, added firmware, and fixed dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 19 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a0693ed3b65..54adea586d64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
pkgname=ubertooth
-pkgver=2018.08.R1
+pkgver=2018.12.R1
+_pkgver=2018-12-R1
pkgrel=1
-pkgdesc="A 2.4 GHz wireless development board suitable for Bluetooth experimentation. Open source hardware and software. Tools only"
-url="http://sourceforge.net/projects/ubertooth/"
+pkgdesc="Open source wireless development platform suitable for Bluetooth experimentation"
+url="https://github.com/greatscottgadgets/ubertooth/"
arch=('x86_64' 'i686')
license=('GPL')
-depends=('bluez-libs' 'libbtbb' 'libusbx' 'libpcap' 'python2-pyside' 'python2-numpy' 'python2-pyusb')
-source=("https://github.com/greatscottgadgets/ubertooth/releases/download/2018-08-R1/ubertooth-2018-08-R1.tar.xz")
-md5sums=('41a5c192c1f0b5df0516f4abd08ac995')
+depends=('bluez-libs' 'libbtbb>=2018.12.R1' 'libusbx' 'libpcap' 'python2-pyside2' 'python2-numpy' 'python2-pyusb' 'qt5-declarative')
+makedepends=('cmake')
+source=("https://github.com/greatscottgadgets/ubertooth/releases/download/${_pkgver}/ubertooth-${_pkgver}.tar.xz")
+sha256sums=('0042daa79db0f4148a0255cdf05aa57006e23ac36edf7024e9e99ccc4892867b')
build() {
- cd "${srcdir}/${pkgname}-2018-08-R1/host/"
+ cd "${srcdir}/${pkgname}-${_pkgver}/host/"
mkdir -p build
cd build
cmake -DENABLE_PYTHON=FALSE -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr -DUDEV_RULES_PATH=${pkgdir}/etc/udev/rules.d -DINSTALL_UDEV_RULES=TRUE -DUDEV_RULES_GROUP=uucp ..
@@ -20,8 +22,17 @@ build() {
}
package() {
- cd "${srcdir}/${pkgname}-2018-08-R1/host/build/"
+ # Runtime
+ cd "${srcdir}/${pkgname}-${_pkgver}/host/build/"
make install
+
+ # GUI
cd ../python/specan_ui
python2 setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+
+ # Firmware
+ install -dm755 "${pkgdir}/usr/share/ubertooth"
+ cd "${srcdir}/ubertooth-${_pkgver}"
+ cp -r "ubertooth-one-firmware-bin" "${pkgdir}/usr/share/ubertooth/ubertooth-one-firmware-bin"
+ cp -r "firmware" "${pkgdir}/usr/share/ubertooth/firmware"
}