summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDoug Penner2018-11-24 11:22:39 -0800
committerDoug Penner2018-11-24 11:22:39 -0800
commita7c929d642c17fa94f548665d43b779c97e4394e (patch)
treeb7584dba314615d85a4f7410df0769b5c502db8e /PKGBUILD
parentd640df5ab85472f07b11a02637866ac475e7e568 (diff)
downloadaur-a7c929d642c17fa94f548665d43b779c97e4394e.tar.gz
Updated to new release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 78f02cf394fe..3a0693ed3b65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
pkgname=ubertooth
-pkgver=2015.10.R1
+pkgver=2018.08.R1
pkgrel=1
pkgdesc="A 2.4 GHz wireless development board suitable for Bluetooth experimentation. Open source hardware and software. Tools only"
url="http://sourceforge.net/projects/ubertooth/"
arch=('x86_64' 'i686')
license=('GPL')
-depends=('libbtbb' 'libusbx' 'libpcap' 'python')
-source=("https://github.com/greatscottgadgets/ubertooth/releases/download/2015-10-R1/ubertooth-2015-10-R1.tar.xz")
-md5sums=('9d08c87c34c48a4af116e260bd9d12c0')
+depends=('bluez-libs' 'libbtbb' 'libusbx' 'libpcap' 'python2-pyside' 'python2-numpy' 'python2-pyusb')
+source=("https://github.com/greatscottgadgets/ubertooth/releases/download/2018-08-R1/ubertooth-2018-08-R1.tar.xz")
+md5sums=('41a5c192c1f0b5df0516f4abd08ac995')
build() {
- cd "${srcdir}/${pkgname}-2015-10-R1/host/"
+ cd "${srcdir}/${pkgname}-2018-08-R1/host/"
mkdir -p build
cd build
- cmake -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr ..
+ cmake -DENABLE_PYTHON=FALSE -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr -DUDEV_RULES_PATH=${pkgdir}/etc/udev/rules.d -DINSTALL_UDEV_RULES=TRUE -DUDEV_RULES_GROUP=uucp ..
make
+ cd ../python/specan_ui
+ python2 setup.py build
}
package() {
- cd "${srcdir}/${pkgname}-2015-10-R1/host/build/"
+ cd "${srcdir}/${pkgname}-2018-08-R1/host/build/"
make install
+ cd ../python/specan_ui
+ python2 setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
}
-