summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorabbypan2017-06-15 10:05:21 +0800
committerabbypan2017-06-15 10:05:21 +0800
commit12863f3d8a19465f390e180519a1ed585981c06e (patch)
tree85455bdc7b55c01e48bd8100c939012bf38bb100 /PKGBUILD
downloadaur-12863f3d8a19465f390e180519a1ed585981c06e.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25ac6e4882ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+_gitname=ubertooth
+pkgname=ubertooth-git
+pkgver=2017.03.R2
+epoch=2
+pkgrel=1
+pkgdesc="an open source wireless development platform suitable for Bluetooth experimentation"
+url="https://github.com/greatscottgadgets/ubertooth"
+arch=('x86_64' 'i686')
+license=('GPL2')
+depends=('libbtbb' 'libusbx' 'libpcap' 'python')
+source=("https://github.com/greatscottgadgets/ubertooth/archive/master.zip")
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${_gitname}-master/host/"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr ..
+ make
+}
+
+package() {
+ cd "${srcdir}/${_gitname}-master/host/build/"
+ make install
+}