summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthias Lisin2019-10-30 00:47:31 +0100
committerMatthias Lisin2019-10-30 00:47:31 +0100
commit837cec2a29149566b224600048c8e9d1a25f8344 (patch)
treece57d548af5ba10a9d4fc0e1323025a1736f8b8e /PKGBUILD
parentf98748263a000738a1500b0dc835320bac74a430 (diff)
downloadaur-837cec2a29149566b224600048c8e9d1a25f8344.tar.gz
upgpkg: ubports-installer-git 3e68c62a
- Update disable-update-check.patch - Force use of system android-tools
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6e07c0cbe6fc..24342ca4cad0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Matthias Lisin <ml@visu.li>
pkgname=ubports-installer-git
-pkgver=0.3.2_beta.r6.g15ed833
-pkgrel=2
+pkgver=0.4.2_beta.r5.g3e68c62
+pkgrel=1
pkgdesc='A simple tool to install Ubuntu Touch on UBports devices'
arch=(any)
url='https://github.com/ubports/ubports-installer'
@@ -13,11 +13,13 @@ conflicts=('ubports-installer')
source=("$pkgname::git+${url}.git"
ubports-installer
ubports-installer.desktop
- disable-update-check.patch)
+ disable-update-check.patch
+ use-system-tools.patch)
sha512sums=('SKIP'
- 'e746e844f013c85f9ef6db7163b08e34745c48de2f94f096c582e6aa89b6cde54a91eca23e2eea0e0d6cb20f2582a0e33456c2503be45d6632bb0e02eb5b4cf1'
+ '478766bca96e64cb13b86003113e33eba74139e5a0d56687ff0647e4d2356639249c9f4054c5c3741fec697c624980dd1507925702f4865370ec9a20f766720a'
'efb0da575db03326f56a8bb589f3f5f543a4ae23b471658555bb030bcc1c1625ba2aafd15f26fac41425b3b0bde4cf176740d92aafd5853d5ce1da2b946686e8'
- '027f2085245135b3aff6e5340b00be55199161d7409788cd800028518c8e03a365c7b5cac762b817e3f71f8d719fdd6bb546807fcda5e64ef6ef11adca4a5c02')
+ '7ed6bf81fa0bbf0dd9a256b9f0ac3e086210f493c398289674c9a41d3ec0d8af36387faf95d700bdfd5b2337f9a3f12e5bb7a72499668f5622c69dea25e6f49d'
+ 'bde53f6f98998d2eb864e63fd73e2da146e5d6f985b670112ea4fcb9001ce34bd59a55d2a8c28f8c8b42280c7225de6746f969d827938441c15eb8febdf15981')
pkgver() {
cd "$pkgname"
@@ -26,26 +28,25 @@ pkgver() {
prepare() {
local dist=/usr/lib/electron4
- local version="$(sed s/^v// $dist/version)"
+ local version="$(sed 's/^v//' $dist/version)"
cd "$pkgname"
for i in ${source[@]}; do
case ${i%::*} in
*.patch)
msg2 "Applying ${i}"
- patch -p1 -i "$srcdir/${i}"
+ patch -N -p1 -i "$srcdir/${i}"
;;
esac
done
# Set electronDist and current electronVersion
- mv -v buildconfig-generic.json buildconfig-generic.json.orig
jq '.electronDist = $dist | .electronVersion = $version' \
--arg dist "$dist" \
--arg version "$version" \
- buildconfig-generic.json.orig > buildconfig-generic.json
+ buildconfig-generic.json | sponge buildconfig-generic.json
- npm uninstall --no-audit --cache "$srcdir/npm-cache" electron{-packager,-view-renderer} spectron
+ npm uninstall --no-audit --cache "$srcdir/npm-cache" electron-packager
# Removing local references
for module in he sshpk; do