summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsehraf2018-04-07 13:18:14 +0200
committersehraf2018-04-07 13:18:51 +0200
commit61af2b099029ffb05b1f69168ccd3d2dc035abab (patch)
treeacfe9c43c25a2b3bd3cbf80574e39671c57fcadd /PKGBUILD
downloadaur-61af2b099029ffb05b1f69168ccd3d2dc035abab.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfdc16cc758d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: sehraf
+
+_pkgname=ubrb
+pkgname=${_pkgname}-git
+pkgver=v1
+pkgrel=1
+pkgdesc='Store data (e.g. LUKS keyfile) in RAM of external devices'
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url='https://github.com/sehraf/ubrb.git'
+license=('MIT')
+depends=('')
+makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+source=("${_pkgname}::git+https://github.com/sehraf/ubrb.git")
+sha256sums=('SKIP')
+
+#pkgver() {
+# cd "${srcdir}/${_pkgname}"
+# git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+#}
+
+build() {
+ cd "${srcdir}/${_pkgname}/UBRB_HostReceiver"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ install -Dm755 UBRB_HostReceiver/ubrb "${pkgdir}/usr/bin/ubrb"
+
+ install -Dm644 mkinitcpio/hooks/ubrb "${pkgdir}/usr/lib/initcpio/hooks/ubrb"
+ install -Dm644 mkinitcpio/install/ubrb "${pkgdir}/usr/lib/initcpio/install/ubrb"
+ install -Dm644 mkinitcpio/etc/conf.d/ubrb.conf "${pkgdir}/etc/conf.d/ubrb.conf"
+
+ install -Dm644 systemd/ubrb.service "${pkgdir}/usr/lib/systemd/system/ubrb.service"
+}
+