summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUdit Karode2019-07-28 17:04:33 +0000
committerUdit Karode2019-07-28 17:04:33 +0000
commitddf8e87f6701df0155c108bb886f1121ee6b4545 (patch)
tree59517a19e98838bfa4bb9537367c6fcd3d40a39a /PKGBUILD
downloadaur-ddf8e87f6701df0155c108bb886f1121ee6b4545.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 17 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f93f4ec3459d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Udit Karode <udit.karode@gmail.com>
+pkgname="ucc"
+pkgver=2.8
+pkgrel=1
+pkgdesc="A bash based wrapper around the DOS based tcc, lets you compile TurboC(++) programs directly from the terminal."
+arch=("x86_64")
+url="https://github.com/uditkarode/ucc.git"
+license=('sha265')
+depends=('dosbox' 'git' 'wget' 'curl')
+source=(${pkgname}::git+https://github.com/uditkarode/ucc.git)
+md5sums=('SKIP')
+
+package() {
+ install -Dm777 "${pkgname}/ucc" "${pkgdir}/usr/bin/ucc"
+ chmod a+x "${pkgdir}/usr/bin/ucc"
+}
+