summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsinkuu2016-04-24 09:40:41 +0900
committersinkuu2016-04-24 09:40:41 +0900
commite177f2326b66265061c8a7963138e13265a2bfb4 (patch)
tree4071f18f10e971c28a546e528508fa318ceb6d03 /PKGBUILD
downloadaur-e177f2326b66265061c8a7963138e13265a2bfb4.tar.gz
uclogic-tools-4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb957952d1cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: sinkuu <sinkuupump@gmail.com>
+
+pkgname=uclogic-tools
+pkgver=4
+pkgrel=1
+pkgdesc="Show diagnostic information from UC-Logic graphics tablets (rebranded as Huion, Yiynova, Ugee, Monoprice, Turcom and others)"
+arch=('i686' 'x86_64')
+url="https://github.com/DIGImend/uclogic-tools"
+license=('GPL2')
+depends=('libusb')
+source=("https://github.com/DIGImend/uclogic-tools/releases/download/v$pkgver/uclogic-tools-$pkgver.tar.gz")
+sha1sums=('d8bbbe49490bb6681e55fc6790d31c787b7bf3d5')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="${pkgdir}" install
+}