summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgammy2019-05-19 12:41:25 +0200
committergammy2019-05-19 12:41:25 +0200
commit85baa93aa5543c4f435edc4f532f0eb2db95bab7 (patch)
treeec3907e33c87dbdc60380446441be142f1e3683f /PKGBUILD
parenta0580eb87e5f5cd2e3a8ae41bbb382ffb2a15982 (diff)
downloadaur-85baa93aa5543c4f435edc4f532f0eb2db95bab7.tar.gz
Create fix_libcd64_libieee1284.diff which amends a linking error if libieee1284 *is* installed already. Add libieee1284 as an optional dependency. Turn Paula Breton's CFLAGS Makefile hack into a proper patchfile. Minor adjustments to build file.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 15 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 60afd577a39a..8c4a3d3eb624 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Kristian Gunstone <kristian.gunstone.butnotthispart@pean.northis.org>
+# Contributor: Hugo Arpin ("harpin")
# Contributor: Paula Breton <paula@parashep.com>
# Contributor: robb_force <robb_force@holybuffalo.net>
@@ -10,30 +11,29 @@ arch=('i686' 'x86_64')
url="http://ucon64.sourceforge.net/index.php"
license=('GPL')
depends=('zlib' 'libusb-compat')
+optdepends=('libieee1284: libcd64 enhancements')
source=(https://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}-src.tar.gz)
sha256sums=('c99964060a5337cea811b27c4103e186a14ba1f04b19cff08bac0260271bc872')
+source+=(fix_makefile_cflags.diff)
+sha256sums+=('8f1532c4c35b98af34b3c1dc3bdeaa6c2183c7927be69ce396895491d7e8feff')
+source+=(fix_libcd64_libieee1284.diff)
+sha256sums+=('19efc5d87c07c11797fba657f25619c70fa175d100688eafd1094d14baad1255')
+
+srcroot="${pkgname}-${pkgver}-src/"
prepare()
{
- # This quickfix, which amends a typo in the Makefile resulting in
- # misinterpreting CFLAGS, was added by the previous maintainer.
- #
- # Here's an example of what happens without the end quotation, with a
- # CFLAGS variable containing spaces:
- #
- # $ CFLAGS="-O2 -ggdb3" make
- # cd libdiscmage && CFLAGS=-O2 -ggdb3 LDFLAGS= make
- # /bin/sh: -ggdb3: command not found
- # make: *** [Makefile:243: libdiscmage/discmage.so] Error 127
- # $
- #
- #
- sed -i 's|$(CFLAGS0)|"$(CFLAGS0)"|g' ${pkgname}-${pkgver}-src/src/Makefile
+ echo "Applying Makefile CFLAGS fix"
+ patch -d "${srcroot}" -p1 < "../fix_makefile_cflags.diff"
+
+ # Thanks harpin from the aur forums for pointing this bug out!
+ echo "Applying libcd64 ieee1284 shared library fix"
+ patch -d "${srcroot}" -p1 < "../fix_libcd64_libieee1284.diff"
}
build()
{
- cd ${pkgname}-${pkgver}-src/src
+ cd "${srcroot}/src"
./configure --prefix=/usr --with-libusb --with-libcd64
make
}