summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgammy2018-03-23 22:30:06 +0100
committergammy2018-03-23 22:30:45 +0100
commita0580eb87e5f5cd2e3a8ae41bbb382ffb2a15982 (patch)
treefe0f54a325c67c5994fff3a3701497f9cae1e21b /PKGBUILD
parentc5f1a2ec1cd66310195834c87e192157678006f0 (diff)
downloadaur-a0580eb87e5f5cd2e3a8ae41bbb382ffb2a15982.tar.gz
Update package for 2.1.0. Build with libusb and libcd64
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 33 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f01b86d5875f..60afd577a39a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,47 @@
-# Maintainer : Paula Breton <paula@parashep.com>
+# Maintainer: Kristian Gunstone <kristian.gunstone.butnotthispart@pean.northis.org>
+# Contributor: Paula Breton <paula@parashep.com>
# Contributor: robb_force <robb_force@holybuffalo.net>
pkgname=ucon64
-pkgver=2.0.3
+pkgver=2.1.0
pkgrel=1
-pkgdesc="A ROM backup tool and emulator's Swiss Army knife program."
+pkgdesc="A ROM backup tool and emulator's Swiss Army knife program. "
arch=('i686' 'x86_64')
url="http://ucon64.sourceforge.net/index.php"
license=('GPL')
-depends=('zlib')
-source=(https://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}-src.tar.gz \
- patch-ucon64_misc.c)
-sha256sums=('fdf158a4bc7c3a7d45a60ef495151f635ce39938799d373a29628f5985790bd2'
- 'f52d6e0cb307a2c0bc4e4ede0673139f5ddd704199ee12d15f58d2e394f25c80')
+depends=('zlib' 'libusb-compat')
+source=(https://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}-src.tar.gz)
+sha256sums=('c99964060a5337cea811b27c4103e186a14ba1f04b19cff08bac0260271bc872')
-prepare() {
- cd ${pkgname}-${pkgver}-src/src
-
- patch -p0 < ../../patch-ucon64_misc.c
- sed -i 's|$(CFLAGS0)|"$(CFLAGS0)"|g' Makefile
+prepare()
+{
+ # This quickfix, which amends a typo in the Makefile resulting in
+ # misinterpreting CFLAGS, was added by the previous maintainer.
+ #
+ # Here's an example of what happens without the end quotation, with a
+ # CFLAGS variable containing spaces:
+ #
+ # $ CFLAGS="-O2 -ggdb3" make
+ # cd libdiscmage && CFLAGS=-O2 -ggdb3 LDFLAGS= make
+ # /bin/sh: -ggdb3: command not found
+ # make: *** [Makefile:243: libdiscmage/discmage.so] Error 127
+ # $
+ #
+ #
+ sed -i 's|$(CFLAGS0)|"$(CFLAGS0)"|g' ${pkgname}-${pkgver}-src/src/Makefile
}
-build() {
- cd ${pkgname}-${pkgver}-src/src
-
- ./configure --prefix=/usr
- make
+build()
+{
+ cd ${pkgname}-${pkgver}-src/src
+ ./configure --prefix=/usr --with-libusb --with-libcd64
+ make
}
-package() {
- cd ${pkgname}-${pkgver}-src/src
+package()
+{
+ cd ${pkgname}-${pkgver}-src/src
- install -Dm775 ucon64 "${pkgdir}"/usr/bin/ucon64
- install -Dm755 libdiscmage/discmage.so "${pkgdir}"/usr/lib/discmage.so
+ install -Dm775 ucon64 "${pkgdir}"/usr/bin/ucon64
+ install -Dm755 libdiscmage/discmage.so "${pkgdir}"/usr/lib/discmage.so
}