summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2016-01-29 11:49:10 +0000
committerGrey Christoforo2016-01-29 11:49:10 +0000
commited4cfd585bf3deed73a4aedfe852210a4dcb994b (patch)
tree6df107041a1b6c77bcb581fd48c28691c9a36bc6 /PKGBUILD
parent10d1f61631e76f853c6d1de9c6cfd6dbf9ec3977 (diff)
downloadaur-ed4cfd585bf3deed73a4aedfe852210a4dcb994b.tar.gz
move .hg.conf to its own file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 12 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06685867ddc7..f407d3c11000 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,12 +9,18 @@ url="http://hgdownload.soe.ucsc.edu/admin/exe/"
license=other
install=$pkgname.install
depends=('mariadb-clients' 'libpng' 'openssl')
-source=(http://hgdownload.soe.ucsc.edu/admin/exe/userApps.v${pkgver}.src.tgz)
-sha1sums=('0294bf61a0ac8c0d57d1e354ad3eb17187cdecb9')
+source=(http://hgdownload.soe.ucsc.edu/admin/exe/userApps.v${pkgver}.src.tgz .hg.conf)
+sha1sums=('0294bf61a0ac8c0d57d1e354ad3eb17187cdecb9'
+ 'ffc9a7064a697476639c46e9280e0b43ac2393b3')
+
+prepare() {
+ cd "${srcdir}/userApps/"
+ make clean
+}
build() {
cd "${srcdir}/userApps/"
- make
+ make all
}
package() {
@@ -23,15 +29,11 @@ package() {
mv bin/ "${pkgdir}/usr/bin/kentUtils/"
mkdir -p "$pkgdir/etc/profile.d"
- echo "export PATH=/usr/bin/kentUtils:"'$PATH' > "$pkgdir/etc/profile.d/kentUtils.sh"
+ echo 'export PATH=/usr/bin/kentUtils:$PATH' > "$pkgdir/etc/profile.d/kentUtils.sh"
mkdir -p "${pkgdir}/opt/kentUtils/"
-cat > "${pkgdir}/opt/kentUtils/.hg.conf" <<EOF
-db.host=genome-mysql.cse.ucsc.edu
-db.user=genomep
-db.password=password
-central.db=hgcentral
-EOF
+
+ cp "${srcdir}/.hd.conf" "${pkgdir}/opt/kentUtils/."
install -D -m644 licenseUcscGenomeBrowser.txt "${pkgdir}/usr/share/licenses/kentUtils/licenseUcscGenomeBrowser.txt"
install -D -m644 GenomeBrowserLicense.pdf "${pkgdir}/usr/share/licenses/kentUtils/GenomeBrowserLicense.pdf"