summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDevin J. Pohly2016-04-12 13:51:49 -0400
committerDevin J. Pohly2016-04-12 13:51:49 -0400
commitd87a73e2bc6d1f4c66a49cc93535f8c936a4d991 (patch)
tree0ca179a5107dc79f4bd2012acb4fa7f8a5d13c58 /PKGBUILD
parent3a6a73a9b77436852e1c2047717ed16ff980d010 (diff)
downloadaur-udf-infusion-git.tar.gz
register/unregister functions with install script
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37cbb9e4618d..43b9e2785172 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=udf-infusion-git
_pkgname=${pkgname%-git}
_reponame=udf_infusion
pkgver=r104.25c3613
-pkgrel=1
+pkgrel=2
pkgdesc="MySQL functionality enhancement UDF"
arch=('i686' 'x86_64')
url="https://github.com/infusion/udf_infusion"
@@ -12,14 +12,22 @@ depends=('gcc-libs')
makedepends=('mysql')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+https://github.com/infusion/udf_infusion")
-sha256sums=(SKIP)
+install="$_pkgname.install"
+source=("git+https://github.com/infusion/udf_infusion"
+ bootstrap.patch)
+sha256sums=('SKIP'
+ '82a19b98f1338b2c73040e82ca60b0cfcdf1907e0ca4ab20de3d66227027108f')
pkgver() {
cd "$_reponame"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$_reponame"
+ patch -Np1 -i "$srcdir/bootstrap.patch"
+}
+
build() {
cd "$_reponame"
./configure --prefix=/usr
@@ -29,4 +37,6 @@ build() {
package() {
cd "$_reponame"
make DESTDIR="$pkgdir/" install
+ install -d "$pkgdir/usr/share/$_pkgname"
+ install -m644 load.sql unload.sql "$pkgdir/usr/share/$_pkgname"
}