summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDavid Felipe Pizarro Naranjo2017-03-23 21:03:24 -0300
committerDavid Felipe Pizarro Naranjo2017-03-23 21:03:24 -0300
commit7f95b96ce89eda83d6a6261c64223a9fd946331e (patch)
tree7013a2fbb75b3fe84b1b7ad1ad0980ec2c8ea7e2 /PKGBUILD
downloadaur-7f95b96ce89eda83d6a6261c64223a9fd946331e.tar.gz
added udisks2-elogind
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e26dcba1553
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: David P. <megver83@openmailbox.org>
+# Contributor: Alexey D. <lq07829icatm@rambler.ru>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+
+pkgname=udisks2-elogind
+pkgver=2.1.8
+pkgrel=2
+pkgdesc="Disk Management Service, version 2"
+arch=('i686' 'x86_64')
+url="http://www.freedesktop.org/wiki/Software/udisks"
+license=('GPL2')
+groups=('elogind-nosystemd')
+depends=('glib2' 'polkit-elogind' 'libatasmart-nosystemd' 'libgudev-nosystemd' 'acl' 'eudev')
+makedepends=('intltool' 'docbook-xsl' 'gobject-introspection' 'python2' 'gnome-common')
+optdepends=('parted: partition management'
+ 'gptfdisk: GUID partition table support'
+ 'ntfs-3g: NTFS filesystem management support'
+ 'dosfstools: VFAT filesystem management support')
+provides=("udisks2=${pkgver}")
+conflicts=('udisks2')
+options=(libtool strip)
+source=(http://udisks.freedesktop.org/releases/udisks-${pkgver}.tar.bz2
+ 'udisks-enable-elogind.patch')
+sha256sums=('da416914812a77e5f4d82b81deb8c25799fd3228d27d52f7bf89a501b1857dda'
+ '52e9157cdf2a1ecc02664205491c9015951213309d08fe18a32f62f54ed93095')
+
+prepare(){
+ cd "udisks-$pkgver"
+ patch -Np 1 -i ${srcdir}/udisks-enable-elogind.patch
+ autoreconf -vfi
+}
+
+build() {
+ cd "udisks-$pkgver"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --sbindir=/usr/bin \
+ --libexecdir=/usr/lib
+ make
+
+ # fix mdadm location
+ sed -i -e 's#/sbin/mdadm#/usr/bin/mdadm#g' \
+ "${srcdir}/udisks-${pkgver}"/data/80-udisks2.rules
+}
+
+package() {
+ cd "udisks-$pkgver"
+ make DESTDIR="$pkgdir" install \
+ bash_completiondir=/usr/share/bash-completion/completions
+}