summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexey D2013-04-22 08:13:28 +0400
committerAlexey D2015-07-07 08:53:04 +0300
commit6876ccc4a124ba984edded5987af3b5784a44e3f (patch)
tree96bb9a6ae88405f6945834d0c2876da3f19ce1cb /PKGBUILD
parent2b0a96f40601163754a2c4167068a3886258ee7d (diff)
downloadaur-6876ccc4a124ba984edded5987af3b5784a44e3f.tar.gz
version 2.1.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 10 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 733639eb7772..b80f874272b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,40 +2,28 @@
# Contributor: Ionut Biru <ibiru@archlinux.org>
pkgname=udisks2-nosystemd
-pkgver=2.1.6
+pkgver=2.1.0
pkgrel=1
pkgdesc="Disk Management Service, version 2"
arch=('i686' 'x86_64')
url="http://www.freedesktop.org/wiki/Software/udisks"
license=('GPL2')
-groups=('eudev-base')
-depends=('glib2' 'udev' 'polkit-consolekit' 'libatasmart' 'util-linux' 'libgudev')
-makedepends=('intltool' 'docbook-xsl' 'gobject-introspection' 'python2')
+depends=('glib2' 'udev' 'polkit-consolekit' 'libatasmart' 'eject')
+makedepends=('intltool' 'docbook-xsl' 'gobject-introspection' 'python')
optdepends=('parted: partition management'
- 'gptfdisk: GUID partition table support'
- 'ntfs-3g: NTFS filesystem management support'
- 'dosfstools: VFAT filesystem management support')
+ 'gptfdisk: GUID partition table support')
provides=("udisks2=${pkgver}")
-conflicts=('udisks2' 'udisks2-eudev')
-replaces=('udisks2' 'udisks2-eudev')
+conflicts=('udisks2')
+replaces=('udisks2')
options=(!libtool)
-source=(http://udisks.freedesktop.org/releases/udisks-${pkgver}.tar.bz2)
-sha256sums=('dec5f5c85fa0f74f39336acbfba1770f9988c096be23873714543c304b09f46a')
+source=(http://udisks.freedesktop.org/releases/udisks-$pkgver.tar.bz2)
+sha256sums=('310208e5a10335dae4b52a0125c24d31cf292cce3d15cf65da4cd308e38d15a8')
build() {
cd "udisks-$pkgver"
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --disable-static \
- --sbindir=/usr/bin \
- --libexecdir=/usr/lib
+ ./configure --prefix=/usr --sysconfdir=/etc \
+ --localstatedir=/var --disable-static
make
-
- # fix mdadm location
- sed -i -e 's#/sbin/mdadm#/usr/bin/mdadm#g' \
- "${srcdir}/udisks-${pkgver}"/data/80-udisks2.rules
}
package() {