summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJustKidding2023-04-25 09:10:45 -0500
committerJustKidding2023-04-25 09:10:45 -0500
commita521db2cbbadd705ea3483bb3dfc23858db84dac (patch)
tree9ab358c02b2862947a9d8735a77fdda789e9e40e /PKGBUILD
parentec22ba5a6306fb077510a1ac28e43634f2ef69a6 (diff)
downloadaur-a521db2cbbadd705ea3483bb3dfc23858db84dac.tar.gz
upgpkg: ueberzugpp 2.7.8-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c99c84bec390..788165e33af1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
pkgname=ueberzugpp
-pkgver=2.7.7
+pkgver=2.7.8
pkgrel=1
pkgdesc="Command line util which allows to display images in combination with X11 written in C++"
arch=("x86_64")
url="https://github.com/jstkdng/ueberzugpp"
license=("GPL3")
makedepends=("cmake" "cli11")
-depends=("opencv" "libvips" "xcb-util-image" "nlohmann-json" "libsixel" "openssl" "spdlog" "zeromq" "fmt")
+depends=("opencv" "libvips" "xcb-util-image" "nlohmann-json" "libsixel" "openssl" "spdlog" "zeromq" "fmt" "turbo-base64")
source=("https://github.com/jstkdng/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('0a1ab82faadf9742bf873813b88e393645e9af3f53495b465a942ea25c495cc2')
+sha256sums=('3249f591db82c6e6c3faf4d590b3e30466667686057e982259cd1b27da48bd11')
provides=("ueberzug")
conflicts=("ueberzug")
@@ -16,6 +16,7 @@ build() {
cmake -B build -S "$pkgname-$pkgver" \
-DCMAKE_BUILD_TYPE='None' \
-DCMAKE_INSTALL_PREFIX='/usr' \
+ -DENABLE_TURBOBASE64=ON \
-Wno-dev
cmake --build build -j $(nproc)
}