summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgesh2021-03-08 15:00:00 +0000
committerJoel Noyce Barnham2021-05-04 22:08:50 +0100
commit67430e82173fa5535a87bfbc647333783666ecec (patch)
tree5aa57988748d0db113caae3fc3935ed371f69cd0 /PKGBUILD
parent30e154b2feea9d636a238fbf66523197cb29f677 (diff)
downloadaur-67430e82173fa5535a87bfbc647333783666ecec.tar.gz
Move _submod_path to _prepare_tianocore_sources()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7fcb2856ecf7..7f6c5f73864d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -45,14 +45,6 @@ provides=('uefi-shell')
install="${_pkgname}.install"
-declare -A _submod_path
-_submod_path["CryptoPkg/Library/OpensslLib/openssl"]="openssl"
-_submod_path["SoftFloat"]="softfloat"
-_submod_path["UnitTestFrameworkPkg/Library/CmockaLib/cmocka"]="cmocka"
-_submod_path["MdeModulePkg/Universal/RegularExpressionDxe/oniguruma"]="oniguruma"
-_submod_path["MdeModulePkg/Library/BrotliCustomDecompressLib/brotli"]="brotli"
-_submod_path["BaseTools/Source/C/BrotliCompress/brotli"]="brotli"
-
source=(
"${_TIANO_DIR_}::git+https://github.com/tianocore/edk2.git#branch=master"
"brotli::git+https://github.com/google/brotli"
@@ -85,6 +77,14 @@ _setup_env_vars() {
_prepare_tianocore_sources() {
cd "${_UDK_DIR}/"
+ declare -A _submod_path
+ _submod_path["CryptoPkg/Library/OpensslLib/openssl"]="openssl"
+ _submod_path["SoftFloat"]="softfloat"
+ _submod_path["UnitTestFrameworkPkg/Library/CmockaLib/cmocka"]="cmocka"
+ _submod_path["MdeModulePkg/Universal/RegularExpressionDxe/oniguruma"]="oniguruma"
+ _submod_path["MdeModulePkg/Library/BrotliCustomDecompressLib/brotli"]="brotli"
+ _submod_path["BaseTools/Source/C/BrotliCompress/brotli"]="brotli"
+
msg "Updating submodules"
git submodule init
for _module in "${!_submod_path[@]}"; do