summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGesh2020-11-02 21:35:24 +0000
committerJoel Noyce Barnham2020-11-10 22:59:25 +0000
commitcc7735bac4bcdb6654983223f6218a3f901a20b4 (patch)
tree942fc11f861e610bac83206bf719b038ab42b75b /PKGBUILD
parent2425be61fa548adc3a757e53aaf2fad34232589e (diff)
downloadaur-cc7735bac4bcdb6654983223f6218a3f901a20b4.tar.gz
Fix build after submodulification
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 29 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 15bfff1b4bfc..0a932d1bd6a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,8 +29,8 @@ _GUID="EA4BB293-2D7F-4456-A681-1F22F42CD0BC"
_pkgname="uefi-shell"
pkgname="${_pkgname}-git"
-pkgver=28256.edk2.stable201903.2519.g1366cd58cd
-pkgrel=2
+pkgver=28247.edk2.stable201903.2510.gffddac3e0f
+pkgrel=3
pkgdesc="UEFI Shell v2 - from Tianocore EDK2 - GIT Version"
url="https://github.com/tianocore/edk2"
arch=('x86_64' 'i686')
@@ -45,9 +45,28 @@ provides=('uefi-shell')
install="${_pkgname}.install"
-source=("${_TIANO_DIR_}::git+https://github.com/tianocore/edk2.git#branch=master")
-
-sha1sums=('SKIP')
+declare -A _submod_path
+_submod_path["CryptoPkg/Library/OpensslLib/openssl"]="openssl"
+_submod_path["SoftFloat"]="softfloat"
+_submod_path["UnitTestFrameworkPkg/Library/CmockaLib/cmocka"]="cmocka"
+_submod_path["MdeModulePkg/Universal/RegularExpressionDxe/oniguruma"]="oniguruma"
+_submod_path["MdeModulePkg/Library/BrotliCustomDecompressLib/brotli"]="brotli"
+_submod_path["BaseTools/Source/C/BrotliCompress/brotli"]="brotli"
+
+source=("${_TIANO_DIR_}::git+https://github.com/tianocore/edk2.git#branch=master"
+ brotli::git+https://github.com/google/brotli
+ softfloat::git+https://github.com/ucb-bar/berkeley-softfloat-3.git
+ cmocka::git+https://git.cryptomilk.org/projects/cmocka.git
+ oniguruma::git+https://github.com/kkos/oniguruma
+ openssl::git+https://github.com/openssl/openssl
+ )
+
+sha1sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd "${srcdir}/${_TIANO_DIR_}/"
@@ -63,8 +82,11 @@ _setup_env_vars() {
_prepare_tianocore_sources() {
cd "${_UDK_DIR}/"
- msg "Updating submodules"
- git submodule update --init
+ git submodule init
+ for _module in "${!_submod_path[@]}"; do
+ git config submodule."$_module".url "$srcdir/${_submod_path[$_module]}"
+ done
+ git submodule update
msg "Cleanup UDK config files"
rm -rf "${_UDK_DIR}/Build/" || true