summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCaleb Maclennan2023-05-03 21:30:36 +0300
committerCaleb Maclennan2023-05-03 21:30:36 +0300
commitdd932c9284839d8e78bfdb6e96d67c8fab4743bc (patch)
tree620443e6c172de784b3d50ae2f8c877e747686ca /PKGBUILD
parentae64e7470ffff33ddd44b4a1fd71e961606f6524 (diff)
downloadaur-dd932c9284839d8e78bfdb6e96d67c8fab4743bc.tar.gz
upgpkg: ufodiff 1.0.3-3
Rebuild for Python 3.11, normalize PEP517 build tooling
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 760e02bae062..b7530d2218c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=ufodiff
pkgver=1.0.3
-pkgrel=2
+pkgrel=3
pkgdesc='UFO source file diff application'
arch=(any)
url="https://github.com/source-foundry/$pkgname"
@@ -13,17 +13,18 @@ depends=(python
python-gitpython
python-smmap
python-standardstreams)
-makedepends=(python-setuptools)
+makedepends=(python-{build,installer,wheel}
+ python-setuptools)
_archive="$pkgname-$pkgver"
source=("$_archive.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('e549e7f3598c0cf0a6be207944fb632db0d834addb4cf202ee00967ceebd58dd')
build() {
cd "$_archive"
- python setup.py build
+ python -m build -wn
}
package() {
cd "$_archive"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer -d "$pkgdir" dist/*.whl
}